summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION75
-rw-r--r--php-pecl-sdl.spec7
2 files changed, 77 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 289ccd7..023f727 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #71 SDL version 2.2.2 ] {
+Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
- - Constants [735] {
+ - Constants [738] {
Constant [ int SDL_BLENDMODE_NONE ] { 0 }
Constant [ int SDL_BLENDMODE_BLEND ] { 1 }
Constant [ int SDL_BLENDMODE_ADD ] { 2 }
@@ -22,6 +22,9 @@ Extension [ <persistent> extension #71 SDL version 2.2.2 ] {
Constant [ int SDL_MOUSEBUTTONDOWN ] { 1025 }
Constant [ int SDL_MOUSEBUTTONUP ] { 1026 }
Constant [ int SDL_MOUSEWHEEL ] { 1027 }
+ Constant [ int SDL_JOYAXISMOTION ] { 1536 }
+ Constant [ int SDL_JOYBUTTONDOWN ] { 1539 }
+ Constant [ int SDL_JOYBUTTONUP ] { 1540 }
Constant [ int SDL_WINDOWEVENT_SHOWN ] { 1 }
Constant [ int SDL_WINDOWEVENT_HIDDEN ] { 2 }
Constant [ int SDL_WINDOWEVENT_EXPOSED ] { 3 }
@@ -2233,6 +2236,54 @@ Extension [ <persistent> extension #71 SDL version 2.2.2 ] {
Parameter #0 [ <required> SDL_cond $condition ]
}
}
+ Function [ <internal:SDL> function SDL_NumJoysticks ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:SDL> function SDL_JoystickOpen ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $index ]
+ }
+ }
+ Function [ <internal:SDL> function SDL_JoystickClose ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> SDL_Joystick $joystick ]
+ }
+ }
+ Function [ <internal:SDL> function SDL_JoystickNumButtons ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> SDL_Joystick $joystick ]
+ }
+ }
+ Function [ <internal:SDL> function SDL_JoystickName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> SDL_Joystick $joystick ]
+ }
+ }
+ Function [ <internal:SDL> function SDL_JoystickGetAxis ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> SDL_Joystick $joystick ]
+ Parameter #1 [ <required> int $axis ]
+ }
+ }
+ Function [ <internal:SDL> function SDL_JoystickNameForIndex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $index ]
+ }
+ }
+ Function [ <internal:SDL> function SDL_IsGameController ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $index ]
+ }
+ }
Function [ <internal:SDL> function SDL_AllocRW ] {
- Parameters [0] {
@@ -2409,7 +2460,7 @@ Extension [ <persistent> extension #71 SDL version 2.2.2 ] {
}
}
- - Classes [20] {
+ - Classes [21] {
Class [ <internal:SDL> class SDL_Event ] {
- Constants [0] {
@@ -4276,6 +4327,24 @@ Extension [ <persistent> extension #71 SDL version 2.2.2 ] {
}
}
}
+
+ Class [ <internal:SDL> class SDL_Joystick ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/php-pecl-sdl.spec b/php-pecl-sdl.spec
index f6cf57d..2a9eadc 100644
--- a/php-pecl-sdl.spec
+++ b/php-pecl-sdl.spec
@@ -14,8 +14,8 @@
Summary: Simple DirectMedia Layer for PHP
Name: %{?scl_prefix}php-pecl-sdl
-Version: 2.2.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.3.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/sdl
@@ -188,6 +188,9 @@ fi
%changelog
+* Sun Sep 8 2019 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- update to 2.3.0
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 2.2.2-2
- rebuild for 7.4.0RC1