summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-scrypt.spec9
-rw-r--r--scrypt-pr47.patch39
3 files changed, 10 insertions, 44 deletions
diff --git a/REFLECTION b/REFLECTION
index c5505f9..4c8aa57 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,8 @@
-Extension [ <persistent> extension #154 scrypt version 1.4 ] {
+Extension [ <persistent> extension #154 scrypt version 1.4.2 ] {
+
+ - Dependencies {
+ Dependency [ hash (Required) ]
+ }
- Functions {
Function [ <internal:scrypt> function scrypt ] {
diff --git a/php-pecl-scrypt.spec b/php-pecl-scrypt.spec
index 8a4f546..c2d2314 100644
--- a/php-pecl-scrypt.spec
+++ b/php-pecl-scrypt.spec
@@ -25,15 +25,13 @@
Summary: Scrypt hashing function
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.4
+Version: 1.4.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-pr47.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
@@ -95,7 +93,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr47
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SCRYPT_VERSION/{s/.* "//;s/".*$//;p}' php_scrypt.h)
@@ -231,6 +228,10 @@ rm -rf %{buildroot}
%changelog
+* Wed May 18 2016 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
+- Update to 1.4.2
+- drop patches, all merged upstream
+
* Wed May 18 2016 Remi Collet <remi@fedoraproject.org> - 1.4-1
- Update to 1.4 (php 5 and 7, stable)
- open https://github.com/DomBlack/php-scrypt/issues/46 failed test
diff --git a/scrypt-pr47.patch b/scrypt-pr47.patch
deleted file mode 100644
index 459c153..0000000
--- a/scrypt-pr47.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 52f0b3dbc28a2acbcce356ee657081ff12acd20d Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Wed, 18 May 2016 14:59:34 +0200
-Subject: [PATCH] fix zend_parse_parameters call, fix #46
-
----
- php_scrypt.c | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/php_scrypt.c b/php_scrypt.c
-index 97c38f1..df1f04f 100644
---- a/php_scrypt.c
-+++ b/php_scrypt.c
-@@ -43,6 +43,12 @@
-
- #include "math.h"
-
-+#if PHP_MAJOR_VERSION >= 7
-+typedef size_t strsize_t;
-+#else
-+typedef int strsize_t;
-+#endif
-+
- /* {{{ arginfo */
- ZEND_BEGIN_ARG_INFO_EX(scrypt_arginfo, 0, 0, 6)
- ZEND_ARG_INFO(0, password)
-@@ -115,10 +121,10 @@ PHP_FUNCTION(scrypt)
- {
- /* Variables for PHP's parameters */
- unsigned char *password;
-- int password_len;
-+ strsize_t password_len;
-
- unsigned char *salt;
-- int salt_len;
-+ strsize_t salt_len;
-
- long phpN;
- long phpR;