summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-sandbox.spec10
-rw-r--r--sandbox-php74.patch23
2 files changed, 31 insertions, 2 deletions
diff --git a/php-pecl-sandbox.spec b/php-pecl-sandbox.spec
index cb9f2a4..76e6501 100644
--- a/php-pecl-sandbox.spec
+++ b/php-pecl-sandbox.spec
@@ -14,10 +14,12 @@
Summary: Isolated environment
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.1.2
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%%{pecl_name}-%{version}.tgz
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+Patch0: %{pecl_name}-php74.patch
BuildRequires: %{?scl_prefix}php-zts-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
@@ -100,6 +102,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{pecl_name}-%{version}
+%patch0 -p1
# Sanity check, really often broken
extver=$(sed -n '/define PHP_SANDBOX_VERSION/{s/.* "//;s/".*$//;p}' php_sandbox.h)
@@ -193,6 +196,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 0.1.2-2
+- add suptream patch for 7.4.0RC1
+
* Fri Jun 14 2019 Remi Collet <remi@remirepo.net> - 0.1.2-1
- update to 0.1.2
diff --git a/sandbox-php74.patch b/sandbox-php74.patch
new file mode 100644
index 0000000..323381b
--- /dev/null
+++ b/sandbox-php74.patch
@@ -0,0 +1,23 @@
+From c4b8428acca58387d80698d3428a53148ac72a7e Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 6 Sep 2019 11:04:22 +0200
+Subject: [PATCH] fix for 7.4
+
+---
+ src/copy.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/copy.c b/src/copy.c
+index c0af965..e2f959b 100644
+--- a/src/copy.c
++++ b/src/copy.c
+@@ -223,7 +223,9 @@ static inline zend_op* php_sandbox_copy_opcodes(zend_op_array *op_array, zval *l
+ case ZEND_JMP:
+ case ZEND_FAST_CALL:
+ case ZEND_DECLARE_ANON_CLASS:
++#if PHP_VERSION_ID < 70400
+ case ZEND_DECLARE_ANON_INHERITED_CLASS:
++#endif
+ opline->op1.jmp_addr = &copy[opline->op1.jmp_addr - op_array->opcodes];
+ break;
+