summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION22
-rw-r--r--php-pecl-runkit7.spec21
3 files changed, 20 insertions, 25 deletions
diff --git a/PHPINFO b/PHPINFO
index 9097c83..e22efd9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
runkit7
runkit7 support => enabled
-version => 4.0.0a2
+version => 4.0.0a3
Custom Superglobal support => enabled
Runtime Manipulation => enabled
diff --git a/REFLECTION b/REFLECTION
index a9bba1f..f089348 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 runkit7 version 4.0.0a2 ] {
+Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- INI {
Entry [ runkit.superglobal <PERDIR,SYSTEM> ]
@@ -10,16 +10,16 @@ Extension [ <persistent> extension #117 runkit7 version 4.0.0a2 ] {
}
- Constants [16] {
- Constant [ int RUNKIT_ACC_RETURN_REFERENCE ] { 67108864 }
- Constant [ int RUNKIT7_ACC_RETURN_REFERENCE ] { 67108864 }
- Constant [ int RUNKIT_ACC_PUBLIC ] { 256 }
- Constant [ int RUNKIT7_ACC_PUBLIC ] { 256 }
- Constant [ int RUNKIT_ACC_PROTECTED ] { 512 }
- Constant [ int RUNKIT7_ACC_PROTECTED ] { 512 }
- Constant [ int RUNKIT_ACC_PRIVATE ] { 1024 }
- Constant [ int RUNKIT7_ACC_PRIVATE ] { 1024 }
- Constant [ int RUNKIT_ACC_STATIC ] { 1 }
- Constant [ int RUNKIT7_ACC_STATIC ] { 1 }
+ Constant [ int RUNKIT_ACC_RETURN_REFERENCE ] { 4096 }
+ Constant [ int RUNKIT7_ACC_RETURN_REFERENCE ] { 4096 }
+ Constant [ int RUNKIT_ACC_PUBLIC ] { 1 }
+ Constant [ int RUNKIT7_ACC_PUBLIC ] { 1 }
+ Constant [ int RUNKIT_ACC_PROTECTED ] { 2 }
+ Constant [ int RUNKIT7_ACC_PROTECTED ] { 2 }
+ Constant [ int RUNKIT_ACC_PRIVATE ] { 4 }
+ Constant [ int RUNKIT7_ACC_PRIVATE ] { 4 }
+ Constant [ int RUNKIT_ACC_STATIC ] { 16 }
+ Constant [ int RUNKIT7_ACC_STATIC ] { 16 }
Constant [ int RUNKIT_OVERRIDE_OBJECTS ] { 32768 }
Constant [ int RUNKIT7_OVERRIDE_OBJECTS ] { 32768 }
Constant [ int RUNKIT_FEATURE_MANIPULATION ] { 1 }
diff --git a/php-pecl-runkit7.spec b/php-pecl-runkit7.spec
index aeb74d1..8f94dd9 100644
--- a/php-pecl-runkit7.spec
+++ b/php-pecl-runkit7.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-runkit7
#
-# Copyright (c) 2019-2020 Remi Collet
+# Copyright (c) 2019-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,7 +21,7 @@
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 4.0.0
-%global upstream_prever a2
+%global upstream_prever a3
Name: %{?sub_prefix}php-pecl-%{proj_name}
Summary: For all those things you... shouldn't have been doing anyway... but surely do!
@@ -32,6 +32,7 @@ URL: https://pecl.php.net/package/%{proj_name}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
@@ -64,13 +65,10 @@ Obsoletes: php74-pecl-%{proj_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{proj_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{proj_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
%endif
-%{?filter_setup}
%description
@@ -170,12 +168,6 @@ export REPORT_EXIT_STATUS=1
%if %{with_tests}
# ignore FPM tests because of systemd monitoring changing output
rm ?TS/tests/runkit_fpm*
-%if "%{php_version}" > "8.0"
-rm ?TS/tests/runkit_arginfo.phpt
-rm ?TS/tests/runkit_function_copy_8.phpt
-rm ?TS/tests/runkit_method_variadic_strict.phpt
-rm ?TS/tests/runkit_methods_returning_by_reference.phpt
-%endif
: Upstream test suite NTS extension
cd NTS
@@ -234,6 +226,9 @@ fi
%endif
%changelog
+* Sun Jul 18 2021 Remi Collet <remi@remirepo.net> - 4.0.0~a3-1
+- update to 4.0.0a3
+
* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 4.0.0~a2-1
- update to 4.0.0a2