summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION7
-rw-r--r--php-pecl-rpminfo.spec9
3 files changed, 7 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index 43bfb3f..9c7ed87 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,4 +3,4 @@ rpminfo
rpminfo support => enabled
Extension version => 0.5.1
-RPM library version => 4.15.1
+RPM library version => 4.16.1.2
diff --git a/REFLECTION b/REFLECTION
index 0f281d0..464d2e3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
-Extension [ <persistent> extension #98 rpminfo version 0.5.1 ] {
+Extension [ <persistent> extension #100 rpminfo version 0.5.1 ] {
- - Constants [271] {
- Constant [ string RPMVERSION ] { 4.15.1 }
+ - Constants [272] {
+ Constant [ string RPMVERSION ] { 4.16.1.2 }
Constant [ int RPMSENSE_ANY ] { 0 }
Constant [ int RPMSENSE_LESS ] { 2 }
Constant [ int RPMSENSE_GREATER ] { 4 }
@@ -171,6 +171,7 @@ Extension [ <persistent> extension #98 rpminfo version 0.5.1 ] {
Constant [ int RPMTAG_PAYLOADCOMPRESSOR ] { 1125 }
Constant [ int RPMTAG_PAYLOADDIGEST ] { 5092 }
Constant [ int RPMTAG_PAYLOADDIGESTALGO ] { 5093 }
+ Constant [ int RPMTAG_PAYLOADDIGESTALT ] { 5097 }
Constant [ int RPMTAG_PAYLOADFLAGS ] { 1126 }
Constant [ int RPMTAG_PAYLOADFORMAT ] { 1124 }
Constant [ int RPMTAG_PKGID ] { 261 }
diff --git a/php-pecl-rpminfo.spec b/php-pecl-rpminfo.spec
index f236f2e..2fa5c19 100644
--- a/php-pecl-rpminfo.spec
+++ b/php-pecl-rpminfo.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-rpminfo
#
-# Copyright (c) 2018-2020 Remi Collet
+# Copyright (c) 2018-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -28,6 +28,7 @@ License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: pkgconfig(rpm) >= 4.11.3
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -59,12 +60,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
Retrieve RPM information using librpm, from local