summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION9
-rw-r--r--php-pecl-rpminfo.spec10
2 files changed, 17 insertions, 2 deletions
diff --git a/REFLECTION b/REFLECTION
index feb0c3a..94ccbb3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,10 +1,17 @@
-Extension [ <persistent> extension #129 rpminfo version 0.1.2 ] {
+Extension [ <persistent> extension #129 rpminfo version 0.2.0 ] {
- Constants [1] {
Constant [ string RPMVERSION ] { 4.14.1 }
}
- Functions {
+ Function [ <internal:rpminfo> function rpmdbinfo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $full ]
+ }
+ }
Function [ <internal:rpminfo> function rpminfo ] {
- Parameters [3] {
diff --git a/php-pecl-rpminfo.spec b/php-pecl-rpminfo.spec
index eeb21ca..ea52991 100644
--- a/php-pecl-rpminfo.spec
+++ b/php-pecl-rpminfo.spec
@@ -18,7 +18,7 @@
Summary: RPM information
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.1.2
+Version: 0.2.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
@@ -65,6 +65,11 @@ Obsoletes: php72w-pecl-%{pecl_name}
%description
Retrieve RPM information using librpm.
+Available functions:
+- rpmvercmp to compare 2 EVRs
+- rpminfo to retrieve information from a RPM file
+- rpmdbingo to rerieve information from an installed RPM
+
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -212,6 +217,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Feb 8 2018 Remi Collet <remi@remirepo.net> - 0.2.0-1
+- update to 0.2.0 (beta)
+
* Thu Feb 8 2018 Remi Collet <remi@remirepo.net> - 0.1.2-1
- update to 0.1.2