summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-redis6.spec')
-rw-r--r--php-pecl-redis6.spec39
1 files changed, 29 insertions, 10 deletions
diff --git a/php-pecl-redis6.spec b/php-pecl-redis6.spec
index 0fabe47..49df56f 100644
--- a/php-pecl-redis6.spec
+++ b/php-pecl-redis6.spec
@@ -10,9 +10,14 @@
# Please, preserve the changelog entries
#
+# For EL-9
+%{!?__phpize: %global __phpize %{_bindir}/phpize}
+%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
+
%bcond_without tests
-%bcond_without igbinary
-%bcond_without msgpack
+%bcond_with igbinary
+%bcond_with msgpack
+%bcond_with liblzf
%if 0%{?fedora} >= 41 || 0%{?rhel} >= 10
%bcond_without valkey
%else
@@ -23,25 +28,25 @@
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 6.0.2
-#global upstream_prever RC2
+%global upstream_version 6.1.0
+%global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
Summary: Extension for communicating with the Redis key-value store
Name: php-pecl-redis6
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 3%{?dist}
+Release: 1%{?dist}
License: PHP-3.01
URL: https://pecl.php.net/package/redis
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: %{pecl_name}-upstream.patch
+Patch0: %{pecl_name}-tests.patch
ExcludeArch: %{ix86}
BuildRequires: make
BuildRequires: gcc
-BuildRequires: php-devel >= 7.2
+BuildRequires: php-devel >= 7.4
BuildRequires: php-pear
BuildRequires: php-json
%if %{with igbinary}
@@ -50,15 +55,17 @@ BuildRequires: php-pecl-igbinary-devel
%if %{with msgpack}
BuildRequires: php-pecl-msgpack-devel >= 2.0.3
%endif
+%if %{with liblzf}
BuildRequires: pkgconfig(liblzf)
+%endif
BuildRequires: pkgconfig(libzstd) >= 1.3.0
BuildRequires: pkgconfig(liblz4)
# to run Test suite
%if %{with tests}
%if %{with valkey}
-BuildRequires: valkey >= 7
+BuildRequires: valkey
%else
-BuildRequires: redis >= 7
+BuildRequires: redis
%endif
%endif
@@ -100,7 +107,7 @@ The phpredis extension provides an API for communicating
with the Redis key-value store.
This Redis client implements most of the latest Redis API.
-As method only only works when also implemented on the server side,
+As method only works when also implemented on the server side,
some doesn't work with an old redis server version.
@@ -175,6 +182,9 @@ extension = %{pecl_name}.so
;redis.session.lock_retries = 100
;redis.session.lock_wait_time = 20000
;redis.session.early_refresh = 0
+;redis.session.compression = none
+;redis.session.compression_level = 3
+
EOF
@@ -189,8 +199,12 @@ peclconf() {
%if %{with msgpack}
--enable-redis-msgpack \
%endif
+%if %{with liblzf}
--enable-redis-lzf \
--with-liblzf \
+%else
+ --disable-redis-lzf \
+%endif
--enable-redis-zstd \
--with-libzstd \
--enable-redis-lz4 \
@@ -288,6 +302,11 @@ exit $ret
%changelog
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 6.1.0~RC2-1
+- update to 6.1.0RC2
+- fix test suite with redis 6.2 using patch from
+ https://github.com/phpredis/phpredis/pull/2555
+
* Mon Sep 16 2024 Remi Collet <remi@remirepo.net> - 6.0.2-3
- cleanup and modernize spec file