summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION75
-rw-r--r--php-pecl-redis6.spec28
3 files changed, 90 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index 0597691..918358d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
redis
Redis Support => enabled
-Redis Version => 6.1.0
+Redis Version => 6.1.1
Redis Sentinel Version => 1.0
Available serializers => php, json, igbinary, msgpack
Available compression => lzf, zstd, lz4
diff --git a/REFLECTION b/REFLECTION
index bae8635..ba740d7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #116 redis version 6.1.0 ] {
+Extension [ <persistent> extension #131 redis version 6.1.1 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
@@ -115,7 +115,7 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
- Classes [6] {
Class [ <internal:redis> class Redis ] {
- - Constants [50] {
+ - Constants [51] {
Constant [ public int REDIS_NOT_FOUND ] { 0 }
Constant [ public int REDIS_STRING ] { 1 }
Constant [ public int REDIS_SET ] { 2 }
@@ -134,6 +134,7 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
Constant [ public int OPT_REPLY_LITERAL ] { 8 }
Constant [ public int OPT_COMPRESSION_LEVEL ] { 9 }
Constant [ public int OPT_NULL_MULTIBULK_AS_NULL ] { 10 }
+ Constant [ public int OPT_PACK_IGNORE_NUMBERS ] { 15 }
Constant [ public int SERIALIZER_NONE ] { 0 }
Constant [ public int SERIALIZER_PHP ] { 1 }
Constant [ public int SERIALIZER_IGBINARY ] { 2 }
@@ -177,7 +178,7 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
- Properties [0] {
}
- - Methods [255] {
+ - Methods [258] {
Method [ <internal:redis, ctor> public method __construct ] {
- Parameters [1] {
@@ -836,6 +837,14 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
- Return [ mixed ]
}
+ Method [ <internal:redis> public method getWithMeta ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $key ]
+ }
+ - Return [ Redis|array|false ]
+ }
+
Method [ <internal:redis> public method getAuth ] {
- Parameters [0] {
@@ -1122,6 +1131,27 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
- Return [ Redis|array|bool ]
}
+ Method [ <internal:redis> public method expiremember ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $field ]
+ Parameter #2 [ <required> int $ttl ]
+ Parameter #3 [ <optional> ?string $unit = null ]
+ }
+ - Return [ Redis|int|false ]
+ }
+
+ Method [ <internal:redis> public method expirememberat ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $field ]
+ Parameter #2 [ <required> int $timestamp ]
+ }
+ - Return [ Redis|int|false ]
+ }
+
Method [ <internal:redis> public method incr ] {
- Parameters [2] {
@@ -2865,7 +2895,7 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
- Properties [0] {
}
- - Methods [224] {
+ - Methods [228] {
Method [ <internal:redis, ctor> public method __construct ] {
- Parameters [7] {
@@ -3519,6 +3549,22 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
- Return [ mixed ]
}
+ Method [ <internal:redis> public method getdel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $key ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:redis> public method getWithMeta ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $key ]
+ }
+ - Return [ RedisCluster|array|false ]
+ }
+
Method [ <internal:redis> public method getex ] {
- Parameters [2] {
@@ -3703,6 +3749,27 @@ Extension [ <persistent> extension #116 redis version 6.1.0 ] {
- Return [ array|bool ]
}
+ Method [ <internal:redis> public method expiremember ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $field ]
+ Parameter #2 [ <required> int $ttl ]
+ Parameter #3 [ <optional> ?string $unit = null ]
+ }
+ - Return [ Redis|int|false ]
+ }
+
+ Method [ <internal:redis> public method expirememberat ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $field ]
+ Parameter #2 [ <required> int $timestamp ]
+ }
+ - Return [ Redis|int|false ]
+ }
+
Method [ <internal:redis> public method hrandfield ] {
- Parameters [2] {
diff --git a/php-pecl-redis6.spec b/php-pecl-redis6.spec
index fa2ddf0..5f8a4c0 100644
--- a/php-pecl-redis6.spec
+++ b/php-pecl-redis6.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-redis6
#
-# Copyright (c) 2012-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2012-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -25,12 +25,14 @@
# Use keydb instead of redis for tests
%bcond_with keydb
+%global pie_vend phpredis
+%global pie_proj phpredis
%global pecl_name redis
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 6.1.0
+%global upstream_version 6.1.1
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -38,7 +40,7 @@
Summary: PHP extension for interfacing with key-value stores
Name: %{?scl_prefix}php-pecl-redis6
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/redis
Source0: https://pecl.php.net/get/%{sources}.tgz
@@ -80,11 +82,13 @@ Requires: %{?scl_prefix}php-igbinary%{?_isa}
Requires: %{?scl_prefix}php-msgpack%{?_isa}
%endif
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < 3
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Obsoletes: %{?scl_prefix}php-%{pecl_name} < 3
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pie(%{pie_vend}/%{pie_proj}) = %{version}
+Provides: %{?scl_prefix}php-%{pie_vend}-%{pie_proj} = %{version}
%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10 || "%{php_version}" > "8.3"
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 6
@@ -337,6 +341,10 @@ exit $ret
%changelog
+* Tue Mar 18 2025 Remi Collet <remi@remirepo.net> - 6.1.1-0
+- test build for upcoming 6.1.1
+- re-license spec file to CECILL-2.1
+
* Sat Oct 5 2024 Remi Collet <remi@remirepo.net> - 6.1.0-1
- update to 6.1.0