summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-redis4.spec')
-rw-r--r--php-pecl-redis4.spec25
1 files changed, 9 insertions, 16 deletions
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 78d5d49..3b0ae48 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -29,26 +29,16 @@
%global ini_name 50-%{pecl_name}.ini
%endif
%global upstream_version 4.1.0
-%global upstream_prever RC1
+%global upstream_prever RC3
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
-# See https://github.com/phpredis/phpredis/issues/1364
-Source1: https://raw.githubusercontent.com/phpredis/phpredis/develop/tests/regenerateSessionId.php
-Source2: https://raw.githubusercontent.com/phpredis/phpredis/develop/tests/getSessionData.php
-Source3: https://raw.githubusercontent.com/phpredis/phpredis/develop/tests/startSession.php
-
-# See https://github.com/phpredis/phpredis/pull/1365
-Patch0: 1365.patch
-# See https://github.com/phpredis/phpredis/pull/1366
-Patch1: 1366.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -59,6 +49,8 @@ BuildRequires: liblzf-devel
# to run Test suite
%if %{with_tests}
BuildRequires: redis >= 3
+# Temporary
+BuildRequires: jemalloc
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -133,9 +125,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-cp %{SOURCE1} %{SOURCE2} %{SOURCE3} tests/
-%patch0 -p1 -b .pr1365
-%patch1 -p1 -b .pr1366
# Use system library
rm -r liblzf
@@ -339,13 +328,17 @@ fi
%changelog
+* Fri Jun 22 2018 Remi Collet <remi@remirepo.net> - 4.1.0~RC3-1
+- update to 4.1.0RC3 (beta, no change)
+- drop patches merged upstream
+
* Fri Jun 8 2018 Remi Collet <remi@remirepo.net> - 4.1.0~RC1-2
- test build with 7.3
- open https://github.com/phpredis/phpredis/pull/1366
Fix: Warning: time() expects exactly 0 parameters, 1 given ...
* Fri Jun 8 2018 Remi Collet <remi@remirepo.net> - 4.1.0~RC1-1
-- update to 4.1.0RC1
+- update to 4.1.0RC1 (alpha)
- open https://github.com/phpredis/phpredis/pull/1365
use PHP_BINARY instead of php and allow override
- report https://github.com/phpredis/phpredis/issues/1364