summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-redis4.spec')
-rw-r--r--php-pecl-redis4.spec31
1 files changed, 25 insertions, 6 deletions
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 4370def..c91b62d 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -28,8 +28,8 @@
# after 40-igbinary
%global ini_name 50-%{pecl_name}.ini
%endif
-%global upstream_version 4.0.2
-#global upstream_prever RC2
+%global upstream_version 4.1.0
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis4
@@ -39,6 +39,14 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstre
License: PHP
URL: http://pecl.php.net/package/redis
+# See https://github.com/phpredis/phpredis/issues/1364
+Source1: https://raw.githubusercontent.com/phpredis/phpredis/develop/tests/regenerateSessionId.php
+Source2: https://raw.githubusercontent.com/phpredis/phpredis/develop/tests/getSessionData.php
+Source3: https://raw.githubusercontent.com/phpredis/phpredis/develop/tests/startSession.php
+
+# See https://github.com/phpredis/phpredis/pull/1365
+Patch0: 1365.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -123,6 +131,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+cp %{SOURCE1} %{SOURCE2} %{SOURCE3} tests/
+%patch0 -p1 -b .pr1365
# Use system library
rm -r liblzf
@@ -172,6 +182,10 @@ extension = %{pecl_name}.so
;redis.clusters.read_timeout = ''
;redis.clusters.seeds = ''
;redis.clusters.timeout = ''
+;redis.session.locking_enabled = ''
+;redis.session.lock_expire = ''
+;redis.session.lock_retries = ''
+;redis.session.lock_wait_time = ''
EOF
@@ -263,16 +277,16 @@ port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + P
--dir $PWD/data \
--pidfile $pidfile
-sed -e "s/6379/$port/" -i RedisTest.php
+sed -e "s/6379/$port/" -i *.php
# Run the test Suite
ret=0
-%{__php} --no-php-ini \
+export PHPCMD="%{__php} --no-php-ini \
%if %{with_igbin}
--define extension=igbinary.so \
%endif
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- TestRedis.php || ret=1
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so"
+$PHPCMD TestRedis.php || ret=1
# Cleanup
if [ -f $pidfile ]; then
@@ -323,6 +337,11 @@ fi
%changelog
* Wed Apr 25 2018 Remi Collet <remi@remirepo.net> - 4.0.2-1
- update to 4.0.2
+- open https://github.com/phpredis/phpredis/pull/1365
+ use PHP_BINARY instead of php and allow override
+- report https://github.com/phpredis/phpredis/issues/1364
+ missing files in pecl archive
+- add new redis.session.lock* options in provided configuration
* Wed Apr 18 2018 Remi Collet <remi@remirepo.net> - 4.0.1-1
- update to 4.0.1