summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION15
-rw-r--r--php-pecl-redis4.spec20
3 files changed, 20 insertions, 17 deletions
diff --git a/PHPINFO b/PHPINFO
index 01423c7..d3a9250 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
redis
Redis Support => enabled
-Redis Version => 4.2.0RC1
+Redis Version => 4.2.0RC2
Available serializers => php, igbinary
Available compression => lzf
diff --git a/REFLECTION b/REFLECTION
index 6179955..7c3afcb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #192 redis version 4.2.0RC1 ] {
+Extension [ <persistent> extension #193 redis version 4.2.0RC2 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
@@ -833,7 +833,8 @@ Extension [ <persistent> extension #192 redis version 4.2.0RC1 ] {
Method [ <internal:redis> public method multi ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $mode ]
}
}
@@ -1126,9 +1127,10 @@ Extension [ <persistent> extension #192 redis version 4.2.0RC1 ] {
Method [ <internal:redis> public method sRemove ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
+ Parameter #1 [ <required> $member ]
+ Parameter #2 [ <optional> ...$other_members ]
}
}
@@ -1879,9 +1881,10 @@ Extension [ <persistent> extension #192 redis version 4.2.0RC1 ] {
Method [ <internal:redis> public method srem ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
+ Parameter #1 [ <required> $member ]
+ Parameter #2 [ <optional> ...$other_members ]
}
}
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index de69dde..eeb1020 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -29,19 +29,16 @@
%global ini_name 50-%{pecl_name}.ini
%endif
%global upstream_version 4.2.0
-%global upstream_prever RC1
+%global upstream_prever RC2
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
-Patch0: https://github.com/phpredis/phpredis/commit/2e412373c47a574a1215756e79e6512a46e30cdc.patch
-Patch1: https://github.com/phpredis/phpredis/commit/0b97ec3739d99f0778ff827cb58c011b92d27a74.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -130,9 +127,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-%patch1 -p1
-
# Use system library
rm -r liblzf
@@ -276,8 +270,10 @@ port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + P
--dir $PWD/data \
--pidfile $pidfile
-# see https://github.com/phpredis/phpredis/issues/1424
-#sed -e 's/testEval/SkipEval/' -i RedisTest.php
+# see https://github.com/phpredis/phpredis/issues/1437
+%if %{__isa_bits} < 64
+sed -e 's/testXClaim/skipXClaim/' -i RedisTest.php
+%endif
: Run the test Suite
sed -e "s/6379/$port/" -i *.php
@@ -338,6 +334,10 @@ fi
%changelog
+* Fri Oct 26 2018 Remi Collet <remi@remirepo.net> - 4.2.0~RC2-1
+- update to 4.2.0RC2 (beta)
+- open https://github.com/phpredis/phpredis/issues/1437 32-bit failed test
+
* Sun Oct 21 2018 Remi Collet <remi@remirepo.net> - 4.2.0~RC1-2
- test build with upstream patches