summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-12 15:27:00 +0200
committerRemi Collet <remi@remirepo.net>2019-07-12 15:27:00 +0200
commite141b8c31daf83e693a0e950111afca47e497428 (patch)
tree5ad7435d4587bab3378540fb3ddc2565b437fd24
new package
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION28
-rw-r--r--php-pecl-recode.spec202
5 files changed, 246 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..86264c2
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,5 @@
+
+recode
+
+Recode Support => enabled
+Recode extension version => 1.0.0-dev
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..207a4c0
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,28 @@
+Extension [ <persistent> extension #69 recode version 1.0.0-dev ] {
+
+ - Functions {
+ Function [ <internal:recode> function recode_string ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $request ]
+ Parameter #1 [ <required> $str ]
+ }
+ }
+ Function [ <internal:recode> function recode_file ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $request ]
+ Parameter #1 [ <required> $input ]
+ Parameter #2 [ <required> $output ]
+ }
+ }
+ Function [ <internal:recode> function recode ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $request ]
+ Parameter #1 [ <required> $str ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-recode.spec b/php-pecl-recode.spec
new file mode 100644
index 0000000..98f812f
--- /dev/null
+++ b/php-pecl-recode.spec
@@ -0,0 +1,202 @@
+# remirepo spec file for php-pecl-recode
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-recode
+%else
+%global _root_bindir %{_bindir}
+%global _root_libexecdir %{_libexecdir}
+%endif
+
+# https://github.com/php/pecl-text-recode/commits/master
+%global gh_commit 7baf882c9771889dd4333f481af34ed218f2d47d
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner php
+%global gh_project pecl-text-recode
+%global gh_date 20190712
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name recode
+%global with_tests 0%{!?_without_tests:1}
+%global upver 1.0.0
+%global lower DEV
+# After 20-xml
+%global ini_name 30-%{pecl_name}.ini
+
+Summary: A module for PHP applications for using the recode library
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+License: PHP
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{upver}-%{gh_short}.tar.gz
+
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 7.4
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: recode-devel
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+# Set epoch so provides is > 0:7.3
+Obsoletes: %{?scl_prefix}php-%{pecl_name} < 7.4.0
+Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter private shared object
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This module contains an interface to the GNU Recode library. The GNU Recode
+library converts files between various coded character sets and surface
+encodings. When this cannot be achieved exactly, it may get rid of the
+offending characters or fall back on approximations. The library recognises
+or produces nearly 150 different character sets and is able to convert files
+between almost any pair. Most RFC 1345 character sets are supported.
+
+This extension which was previously part of the PHP distribution.
+
+This package is only provided for legacy applications.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+
+cd NTS
+# Check version as upstream often forget to update this
+extver=$(sed -n '/#define PHP_RECODE_VERSION/{s/.* "//;s/".*$//;p}' php_recode.h)
+if test "x${extver}" != "x%{upver}%{?rcver}%{?gh_date:-dev}"; then
+ : Error: Upstream RECODE version is ${extver}, expecting %{upver}%{?rcver}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable "%{pecl_name}" extension module
+extension=%{pecl_name}
+EOF
+
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+%{?dtsenable}
+
+peclconf() {
+%configure \
+ --with-recode \
+ --with-php-config=$1
+}
+
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%check
+cd NTS
+
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_zts}
+cd ../ZTS
+
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%endif
+
+%if %{with_tests}
+cd ../NTS
+
+: Run upstream test suite
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php -q --show-diff
+%endif
+
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license NTS/LICENSE
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Fri Jul 12 2019 Remi Collet <remi@remirepo.net> - 1.0.0~DEV.20190712-1
+- initial package, version 1.0.0-dev