summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-rdkafka6.spec14
3 files changed, 16 insertions, 16 deletions
diff --git a/PHPINFO b/PHPINFO
index b8b9219..7421578 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
rdkafka
rdkafka support => enabled
-version => 6.0.0RC2
-build date => Nov 28 2021 00:00:00
+version => 6.0.0
+build date => Jan 7 2022 00:00:00
librdkafka version (runtime) => 1.8.2
librdkafka version (build) => 1.8.2.255
diff --git a/REFLECTION b/REFLECTION
index c0d73e9..9242dff 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #97 rdkafka version 6.0.0RC2 ] {
+Extension [ <persistent> extension #95 rdkafka version 6.0.0 ] {
- Constants [184] {
Constant [ int RD_KAFKA_CONSUMER ] { 1 }
@@ -302,7 +302,7 @@ Extension [ <persistent> extension #97 rdkafka version 6.0.0RC2 ] {
- Parameters [2] {
Parameter #0 [ <required> string $topic_name ]
- Parameter #1 [ <optional> ?RdKafka\Conf $topic_conf = null ]
+ Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
}
@@ -445,7 +445,7 @@ Extension [ <persistent> extension #97 rdkafka version 6.0.0RC2 ] {
- Parameters [2] {
Parameter #0 [ <required> string $topic_name ]
- Parameter #1 [ <optional> ?RdKafka\Conf $topic_conf = null ]
+ Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
}
@@ -609,7 +609,7 @@ Extension [ <persistent> extension #97 rdkafka version 6.0.0RC2 ] {
- Parameters [2] {
Parameter #0 [ <required> string $topic_name ]
- Parameter #1 [ <optional> ?RdKafka\Conf $topic_conf = null ]
+ Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
}
@@ -682,7 +682,7 @@ Extension [ <persistent> extension #97 rdkafka version 6.0.0RC2 ] {
}
}
- Class [ <internal:rdkafka> class RdKafka\Exception extends Exception implements Stringable, Throwable ] {
+ Class [ <internal:rdkafka> class RdKafka\Exception extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -910,7 +910,7 @@ Extension [ <persistent> extension #97 rdkafka version 6.0.0RC2 ] {
}
}
- Class [ <internal:rdkafka> class RdKafka\KafkaErrorException extends RdKafka\Exception implements Throwable, Stringable ] {
+ Class [ <internal:rdkafka> class RdKafka\KafkaErrorException extends RdKafka\Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1129,7 +1129,7 @@ Extension [ <persistent> extension #97 rdkafka version 6.0.0RC2 ] {
- Parameters [2] {
Parameter #0 [ <required> string $topic_name ]
- Parameter #1 [ <optional> ?RdKafka\Conf $topic_conf = null ]
+ Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
}
diff --git a/php-pecl-rdkafka6.spec b/php-pecl-rdkafka6.spec
index bc5208b..4f9f0d1 100644
--- a/php-pecl-rdkafka6.spec
+++ b/php-pecl-rdkafka6.spec
@@ -1,6 +1,6 @@
-# remirepo/fedora spec file for php-pecl-rdkafka5
+# remirepo/fedora spec file for php-pecl-rdkafka6
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -19,7 +19,7 @@
%global buildver %(pkg-config --silence-errors --modversion rdkafka 2>/dev/null || echo 65536)
%global upstream_version 6.0.0
-%global upstream_prever RC2
+#global upstream_prever RC2
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-%{pecl_name}6
@@ -49,7 +49,7 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || "%{php_version}" > "8.1"
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || "%{php_version}" >= "8.1"
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}5 < 6
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
@@ -66,9 +66,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}4%{?_isa} = %{version}-%{relea
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
@@ -217,6 +214,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Jan 7 2022 Remi Collet <remi@remirepo.net> - 6.0.0-1
+- update to 6.0.0
+
* Sun Nov 28 2021 Remi Collet <remi@remirepo.net> - 6.0.0~RC2-1
- update to 6.0.0RC2
- drop patch merged upstream