summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION35
-rw-r--r--php-pecl-rdkafka-php7.spec10
2 files changed, 20 insertions, 25 deletions
diff --git a/REFLECTION b/REFLECTION
index 9333932..2d6fd26 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,14 +1,14 @@
-Extension [ <persistent> extension #64 rdkafka version 1.0.0 ] {
+Extension [ <persistent> extension #113 rdkafka version 2.0.1 ] {
- - Constants [88] {
+ - Constants [89] {
Constant [ integer RD_KAFKA_CONSUMER ] { 1 }
Constant [ integer RD_KAFKA_OFFSET_BEGINNING ] { -2 }
Constant [ integer RD_KAFKA_OFFSET_END ] { -1 }
Constant [ integer RD_KAFKA_OFFSET_STORED ] { -1000 }
Constant [ integer RD_KAFKA_PARTITION_UA ] { -1 }
Constant [ integer RD_KAFKA_PRODUCER ] { 0 }
- Constant [ integer RD_KAFKA_VERSION ] { 590335 }
- Constant [ integer RD_KAFKA_BUILD_VERSION ] { 590335 }
+ Constant [ integer RD_KAFKA_VERSION ] { 590591 }
+ Constant [ integer RD_KAFKA_BUILD_VERSION ] { 590591 }
Constant [ integer RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
Constant [ integer RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
Constant [ integer RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
@@ -43,6 +43,7 @@ Extension [ <persistent> extension #64 rdkafka version 1.0.0 ] {
Constant [ integer RD_KAFKA_RESP_ERR__AUTHENTICATION ] { -169 }
Constant [ integer RD_KAFKA_RESP_ERR__NO_OFFSET ] { -168 }
Constant [ integer RD_KAFKA_RESP_ERR__OUTDATED ] { -167 }
+ Constant [ integer RD_KAFKA_RESP_ERR__TIMED_OUT_QUEUE ] { -166 }
Constant [ integer RD_KAFKA_RESP_ERR__END ] { -100 }
Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN ] { -1 }
Constant [ integer RD_KAFKA_RESP_ERR_NO_ERROR ] { 0 }
@@ -429,7 +430,7 @@ Extension [ <persistent> extension #64 rdkafka version 1.0.0 ] {
}
}
- Class [ <internal:rdkafka> class RdKafka\Exception extends Exception ] {
+ Class [ <internal:rdkafka> class RdKafka\Exception extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -460,28 +461,28 @@ Extension [ <persistent> extension #64 rdkafka version 1.0.0 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
@@ -610,7 +611,7 @@ Extension [ <persistent> extension #64 rdkafka version 1.0.0 ] {
Property [ <default> private $dr_msg_cb ]
}
- - Methods [12] {
+ - Methods [11] {
Method [ <internal:rdkafka, ctor> public method __construct ] {
- Parameters [1] {
@@ -687,12 +688,6 @@ Extension [ <persistent> extension #64 rdkafka version 1.0.0 ] {
Parameter #1 [ <optional> $topic_conf ]
}
}
-
- Method [ <internal:rdkafka, dtor> final public method __destruct ] {
-
- - Parameters [0] {
- }
- }
}
}
diff --git a/php-pecl-rdkafka-php7.spec b/php-pecl-rdkafka-php7.spec
index 2b16cb8..d9af7e3 100644
--- a/php-pecl-rdkafka-php7.spec
+++ b/php-pecl-rdkafka-php7.spec
@@ -18,8 +18,8 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.0.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -86,9 +86,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-# See https://github.com/arnaud-lb/php-rdkafka/issues/71
-sed -e 's/ LOG_/RD_KAFKA_LOG_/' -i rdkafka.c
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_RDKAFKA_VERSION/{s/.* "//;s/".*$//;p}' php_rdkafka.h)
if test "x${extver}" != "x%{version}"; then
@@ -199,6 +196,9 @@ cd ../ZTS
%changelog
+* Mon Nov 28 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- Update to 2.0.1
+
* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
- rebuild for PHP 7.1 new API version