summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION-DEV252
-rw-r--r--php-pecl-radius-dev.spec346
-rw-r--r--php-pecl-radius.spec2
3 files changed, 1 insertions, 599 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
deleted file mode 100644
index 66971ec..0000000
--- a/REFLECTION-DEV
+++ /dev/null
@@ -1,252 +0,0 @@
-Extension [ <persistent> extension #147 radius version 1.4.0b1 ] {
-
- - Constants [187] {
- Constant [ integer RADIUS_ACCESS_REQUEST ] { 1 }
- Constant [ integer RADIUS_ACCESS_ACCEPT ] { 2 }
- Constant [ integer RADIUS_ACCESS_REJECT ] { 3 }
- Constant [ integer RADIUS_ACCOUNTING_REQUEST ] { 4 }
- Constant [ integer RADIUS_ACCOUNTING_RESPONSE ] { 5 }
- Constant [ integer RADIUS_ACCESS_CHALLENGE ] { 11 }
- Constant [ integer RADIUS_DISCONNECT_REQUEST ] { 40 }
- Constant [ integer RADIUS_DISCONNECT_ACK ] { 41 }
- Constant [ integer RADIUS_DISCONNECT_NAK ] { 42 }
- Constant [ integer RADIUS_COA_REQUEST ] { 43 }
- Constant [ integer RADIUS_COA_ACK ] { 44 }
- Constant [ integer RADIUS_COA_NAK ] { 45 }
- Constant [ integer RADIUS_USER_NAME ] { 1 }
- Constant [ integer RADIUS_USER_PASSWORD ] { 2 }
- Constant [ integer RADIUS_CHAP_PASSWORD ] { 3 }
- Constant [ integer RADIUS_NAS_IP_ADDRESS ] { 4 }
- Constant [ integer RADIUS_NAS_PORT ] { 5 }
- Constant [ integer RADIUS_SERVICE_TYPE ] { 6 }
- Constant [ integer RADIUS_LOGIN ] { 1 }
- Constant [ integer RADIUS_FRAMED ] { 2 }
- Constant [ integer RADIUS_CALLBACK_LOGIN ] { 3 }
- Constant [ integer RADIUS_CALLBACK_FRAMED ] { 4 }
- Constant [ integer RADIUS_OUTBOUND ] { 5 }
- Constant [ integer RADIUS_ADMINISTRATIVE ] { 6 }
- Constant [ integer RADIUS_NAS_PROMPT ] { 7 }
- Constant [ integer RADIUS_AUTHENTICATE_ONLY ] { 8 }
- Constant [ integer RADIUS_CALLBACK_NAS_PROMPT ] { 9 }
- Constant [ integer RADIUS_FRAMED_PROTOCOL ] { 7 }
- Constant [ integer RADIUS_PPP ] { 1 }
- Constant [ integer RADIUS_SLIP ] { 2 }
- Constant [ integer RADIUS_ARAP ] { 3 }
- Constant [ integer RADIUS_GANDALF ] { 4 }
- Constant [ integer RADIUS_XYLOGICS ] { 5 }
- Constant [ integer RADIUS_FRAMED_IP_ADDRESS ] { 8 }
- Constant [ integer RADIUS_FRAMED_IP_NETMASK ] { 9 }
- Constant [ integer RADIUS_FRAMED_ROUTING ] { 10 }
- Constant [ integer RADIUS_FILTER_ID ] { 11 }
- Constant [ integer RADIUS_FRAMED_MTU ] { 12 }
- Constant [ integer RADIUS_FRAMED_COMPRESSION ] { 13 }
- Constant [ integer RADIUS_COMP_NONE ] { 0 }
- Constant [ integer RADIUS_COMP_VJ ] { 1 }
- Constant [ integer RADIUS_COMP_IPXHDR ] { 2 }
- Constant [ integer RADIUS_LOGIN_IP_HOST ] { 14 }
- Constant [ integer RADIUS_LOGIN_SERVICE ] { 15 }
- Constant [ integer RADIUS_LOGIN_TCP_PORT ] { 16 }
- Constant [ integer RADIUS_REPLY_MESSAGE ] { 18 }
- Constant [ integer RADIUS_CALLBACK_NUMBER ] { 19 }
- Constant [ integer RADIUS_CALLBACK_ID ] { 20 }
- Constant [ integer RADIUS_FRAMED_ROUTE ] { 22 }
- Constant [ integer RADIUS_FRAMED_IPX_NETWORK ] { 23 }
- Constant [ integer RADIUS_STATE ] { 24 }
- Constant [ integer RADIUS_CLASS ] { 25 }
- Constant [ integer RADIUS_VENDOR_SPECIFIC ] { 26 }
- Constant [ integer RADIUS_SESSION_TIMEOUT ] { 27 }
- Constant [ integer RADIUS_IDLE_TIMEOUT ] { 28 }
- Constant [ integer RADIUS_TERMINATION_ACTION ] { 29 }
- Constant [ integer RADIUS_CALLED_STATION_ID ] { 30 }
- Constant [ integer RADIUS_CALLING_STATION_ID ] { 31 }
- Constant [ integer RADIUS_NAS_IDENTIFIER ] { 32 }
- Constant [ integer RADIUS_PROXY_STATE ] { 33 }
- Constant [ integer RADIUS_LOGIN_LAT_SERVICE ] { 34 }
- Constant [ integer RADIUS_LOGIN_LAT_NODE ] { 35 }
- Constant [ integer RADIUS_LOGIN_LAT_GROUP ] { 36 }
- Constant [ integer RADIUS_FRAMED_APPLETALK_LINK ] { 37 }
- Constant [ integer RADIUS_FRAMED_APPLETALK_NETWORK ] { 38 }
- Constant [ integer RADIUS_FRAMED_APPLETALK_ZONE ] { 39 }
- Constant [ integer RADIUS_CHAP_CHALLENGE ] { 60 }
- Constant [ integer RADIUS_NAS_PORT_TYPE ] { 61 }
- Constant [ integer RADIUS_ASYNC ] { 0 }
- Constant [ integer RADIUS_SYNC ] { 1 }
- Constant [ integer RADIUS_ISDN_SYNC ] { 2 }
- Constant [ integer RADIUS_ISDN_ASYNC_V120 ] { 3 }
- Constant [ integer RADIUS_ISDN_ASYNC_V110 ] { 4 }
- Constant [ integer RADIUS_VIRTUAL ] { 5 }
- Constant [ integer RADIUS_PIAFS ] { 6 }
- Constant [ integer RADIUS_HDLC_CLEAR_CHANNEL ] { 7 }
- Constant [ integer RADIUS_X_25 ] { 8 }
- Constant [ integer RADIUS_X_75 ] { 9 }
- Constant [ integer RADIUS_G_3_FAX ] { 10 }
- Constant [ integer RADIUS_SDSL ] { 11 }
- Constant [ integer RADIUS_ADSL_CAP ] { 12 }
- Constant [ integer RADIUS_ADSL_DMT ] { 13 }
- Constant [ integer RADIUS_IDSL ] { 14 }
- Constant [ integer RADIUS_ETHERNET ] { 15 }
- Constant [ integer RADIUS_XDSL ] { 16 }
- Constant [ integer RADIUS_CABLE ] { 17 }
- Constant [ integer RADIUS_WIRELESS_OTHER ] { 18 }
- Constant [ integer RADIUS_WIRELESS_IEEE_802_11 ] { 19 }
- Constant [ integer RADIUS_PORT_LIMIT ] { 62 }
- Constant [ integer RADIUS_LOGIN_LAT_PORT ] { 63 }
- Constant [ integer RADIUS_CONNECT_INFO ] { 77 }
- Constant [ integer RADIUS_NAS_IPV6_ADDRESS ] { 95 }
- Constant [ integer RADIUS_FRAMED_INTERFACE_ID ] { 96 }
- Constant [ integer RADIUS_FRAMED_IPV6_PREFIX ] { 97 }
- Constant [ integer RADIUS_LOGIN_IPV6_HOST ] { 98 }
- Constant [ integer RADIUS_FRAMED_IPV6_ROUTE ] { 99 }
- Constant [ integer RADIUS_FRAMED_IPV6_POOL ] { 100 }
- Constant [ integer RADIUS_ERROR_CAUSE ] { 101 }
- Constant [ integer RADIUS_ERROR_CAUSE_RESIDUAL_SESSION_CONTEXT_REMOVED ] { 201 }
- Constant [ integer RADIUS_ERROR_CAUSE_INVALID_EAP_PACKET ] { 202 }
- Constant [ integer RADIUS_ERROR_CAUSE_UNSUPPORTED_ATTRIBUTE ] { 401 }
- Constant [ integer RADIUS_ERROR_CAUSE_MISSING_ATTRIBUTE ] { 402 }
- Constant [ integer RADIUS_ERROR_CAUSE_NAS_IDENTIFICATION_MISMATCH ] { 403 }
- Constant [ integer RADIUS_ERROR_CAUSE_INVALID_REQUEST ] { 404 }
- Constant [ integer RADIUS_ERROR_CAUSE_UNSUPPORTED_SERVICE ] { 405 }
- Constant [ integer RADIUS_ERROR_CAUSE_UNSUPPORTED_EXCEPTION ] { 406 }
- Constant [ integer RADIUS_ERROR_CAUSE_ADMINISTRATIVELY_PROHIBITED ] { 501 }
- Constant [ integer RADIUS_ERROR_CAUSE_REQUEST_NOT_ROUTABLE ] { 502 }
- Constant [ integer RADIUS_ERROR_CAUSE_SESSION_CONTEXT_NOT_FOUND ] { 503 }
- Constant [ integer RADIUS_ERROR_CAUSE_SESSION_CONTEXT_NOT_REMOVABLE ] { 504 }
- Constant [ integer RADIUS_ERROR_CAUSE_OTHER_PROXY_PROCESSING_ERROR ] { 505 }
- Constant [ integer RADIUS_ERROR_CAUSE_RESOURCES_UNAVAILABLE ] { 506 }
- Constant [ integer RADIUS_ERROR_CAUSE_REQUEST_INITIATED ] { 507 }
- Constant [ integer RADIUS_ACCT_STATUS_TYPE ] { 40 }
- Constant [ integer RADIUS_START ] { 1 }
- Constant [ integer RADIUS_STOP ] { 2 }
- Constant [ integer RADIUS_ACCOUNTING_ON ] { 7 }
- Constant [ integer RADIUS_ACCOUNTING_OFF ] { 8 }
- Constant [ integer RADIUS_ACCT_DELAY_TIME ] { 41 }
- Constant [ integer RADIUS_ACCT_INPUT_OCTETS ] { 42 }
- Constant [ integer RADIUS_ACCT_OUTPUT_OCTETS ] { 43 }
- Constant [ integer RADIUS_ACCT_SESSION_ID ] { 44 }
- Constant [ integer RADIUS_ACCT_AUTHENTIC ] { 45 }
- Constant [ integer RADIUS_AUTH_RADIUS ] { 1 }
- Constant [ integer RADIUS_AUTH_LOCAL ] { 2 }
- Constant [ integer RADIUS_AUTH_REMOTE ] { 3 }
- Constant [ integer RADIUS_ACCT_SESSION_TIME ] { 46 }
- Constant [ integer RADIUS_ACCT_INPUT_PACKETS ] { 47 }
- Constant [ integer RADIUS_ACCT_OUTPUT_PACKETS ] { 48 }
- Constant [ integer RADIUS_ACCT_TERMINATE_CAUSE ] { 49 }
- Constant [ integer RADIUS_TERM_USER_REQUEST ] { 1 }
- Constant [ integer RADIUS_TERM_LOST_CARRIER ] { 2 }
- Constant [ integer RADIUS_TERM_LOST_SERVICE ] { 3 }
- Constant [ integer RADIUS_TERM_IDLE_TIMEOUT ] { 4 }
- Constant [ integer RADIUS_TERM_SESSION_TIMEOUT ] { 5 }
- Constant [ integer RADIUS_TERM_ADMIN_RESET ] { 6 }
- Constant [ integer RADIUS_TERM_ADMIN_REBOOT ] { 7 }
- Constant [ integer RADIUS_TERM_PORT_ERROR ] { 8 }
- Constant [ integer RADIUS_TERM_NAS_ERROR ] { 9 }
- Constant [ integer RADIUS_TERM_NAS_REQUEST ] { 10 }
- Constant [ integer RADIUS_TERM_NAS_REBOOT ] { 11 }
- Constant [ integer RADIUS_TERM_PORT_UNNEEDED ] { 12 }
- Constant [ integer RADIUS_TERM_PORT_PREEMPTED ] { 13 }
- Constant [ integer RADIUS_TERM_PORT_SUSPENDED ] { 14 }
- Constant [ integer RADIUS_TERM_SERVICE_UNAVAILABLE ] { 15 }
- Constant [ integer RADIUS_TERM_CALLBACK ] { 16 }
- Constant [ integer RADIUS_TERM_USER_ERROR ] { 17 }
- Constant [ integer RADIUS_TERM_HOST_REQUEST ] { 18 }
- Constant [ integer RADIUS_ACCT_MULTI_SESSION_ID ] { 50 }
- Constant [ integer RADIUS_ACCT_LINK_COUNT ] { 51 }
- Constant [ integer RADIUS_VENDOR_MICROSOFT ] { 311 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_RESPONSE ] { 1 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_ERROR ] { 2 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_PW_1 ] { 3 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_PW_2 ] { 4 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_LM_ENC_PW ] { 5 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_NT_ENC_PW ] { 6 }
- Constant [ integer RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_POLICY ] { 7 }
- Constant [ integer RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_TYPES ] { 8 }
- Constant [ integer RADIUS_MICROSOFT_MS_RAS_VENDOR ] { 9 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_DOMAIN ] { 10 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_CHALLENGE ] { 11 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP_MPPE_KEYS ] { 12 }
- Constant [ integer RADIUS_MICROSOFT_MS_BAP_USAGE ] { 13 }
- Constant [ integer RADIUS_MICROSOFT_MS_LINK_UTILIZATION_THRESHOLD ] { 14 }
- Constant [ integer RADIUS_MICROSOFT_MS_LINK_DROP_TIME_LIMIT ] { 15 }
- Constant [ integer RADIUS_MICROSOFT_MS_MPPE_SEND_KEY ] { 16 }
- Constant [ integer RADIUS_MICROSOFT_MS_MPPE_RECV_KEY ] { 17 }
- Constant [ integer RADIUS_MICROSOFT_MS_RAS_VERSION ] { 18 }
- Constant [ integer RADIUS_MICROSOFT_MS_OLD_ARAP_PASSWORD ] { 19 }
- Constant [ integer RADIUS_MICROSOFT_MS_NEW_ARAP_PASSWORD ] { 20 }
- Constant [ integer RADIUS_MICROSOFT_MS_ARAP_PASSWORD_CHANGE_REASON ] { 21 }
- Constant [ integer RADIUS_MICROSOFT_MS_FILTER ] { 22 }
- Constant [ integer RADIUS_MICROSOFT_MS_ACCT_AUTH_TYPE ] { 23 }
- Constant [ integer RADIUS_MICROSOFT_MS_ACCT_EAP_TYPE ] { 24 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP2_RESPONSE ] { 25 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP2_SUCCESS ] { 26 }
- Constant [ integer RADIUS_MICROSOFT_MS_CHAP2_PW ] { 27 }
- Constant [ integer RADIUS_MICROSOFT_MS_PRIMARY_DNS_SERVER ] { 28 }
- Constant [ integer RADIUS_MICROSOFT_MS_SECONDARY_DNS_SERVER ] { 29 }
- Constant [ integer RADIUS_MICROSOFT_MS_PRIMARY_NBNS_SERVER ] { 30 }
- Constant [ integer RADIUS_MICROSOFT_MS_SECONDARY_NBNS_SERVER ] { 31 }
- Constant [ integer RADIUS_MICROSOFT_MS_ARAP_CHALLENGE ] { 33 }
- Constant [ integer RADIUS_OPTION_NONE ] { 0 }
- Constant [ integer RADIUS_OPTION_TAGGED ] { 1 }
- Constant [ integer RADIUS_OPTION_SALT ] { 2 }
- Constant [ integer RADIUS_MPPE_KEY_LEN ] { 16 }
- }
-
- - Functions {
- Function [ <internal:radius> function radius_auth_open ] {
- }
- Function [ <internal:radius> function radius_acct_open ] {
- }
- Function [ <internal:radius> function radius_close ] {
- }
- Function [ <internal:radius> function radius_strerror ] {
- }
- Function [ <internal:radius> function radius_config ] {
- }
- Function [ <internal:radius> function radius_add_server ] {
- }
- Function [ <internal:radius> function radius_create_request ] {
- }
- Function [ <internal:radius> function radius_put_string ] {
- }
- Function [ <internal:radius> function radius_put_int ] {
- }
- Function [ <internal:radius> function radius_put_attr ] {
- }
- Function [ <internal:radius> function radius_put_addr ] {
- }
- Function [ <internal:radius> function radius_put_vendor_string ] {
- }
- Function [ <internal:radius> function radius_put_vendor_int ] {
- }
- Function [ <internal:radius> function radius_put_vendor_attr ] {
- }
- Function [ <internal:radius> function radius_put_vendor_addr ] {
- }
- Function [ <internal:radius> function radius_send_request ] {
- }
- Function [ <internal:radius> function radius_get_attr ] {
- }
- Function [ <internal:radius> function radius_get_tagged_attr_data ] {
- }
- Function [ <internal:radius> function radius_get_tagged_attr_tag ] {
- }
- Function [ <internal:radius> function radius_get_vendor_attr ] {
- }
- Function [ <internal:radius> function radius_cvt_addr ] {
- }
- Function [ <internal:radius> function radius_cvt_int ] {
- }
- Function [ <internal:radius> function radius_cvt_string ] {
- }
- Function [ <internal:radius> function radius_salt_encrypt_attr ] {
- }
- Function [ <internal:radius> function radius_request_authenticator ] {
- }
- Function [ <internal:radius> function radius_server_secret ] {
- }
- Function [ <internal:radius> function radius_demangle ] {
- }
- Function [ <internal:radius> function radius_demangle_mppe_key ] {
- }
- }
-}
-
diff --git a/php-pecl-radius-dev.spec b/php-pecl-radius-dev.spec
deleted file mode 100644
index fedcd2e..0000000
--- a/php-pecl-radius-dev.spec
+++ /dev/null
@@ -1,346 +0,0 @@
-# remirepo spec file for php-pecl-radius
-# adapted for SCL, from:
-#
-# Fedora spec file for php-pecl-radius
-#
-# Copyright (c) 2009-2017 Remi Collet
-# Copyright (c) 2006-2009 Christopher Stone
-#
-# License: MIT
-# http://opensource.org/licenses/MIT
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
-%global sub_prefix %{scl_prefix}
-%endif
-%endif
-
-%{?scl: %scl_package php-pecl-radius}
-
-%global pecl_name radius
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
-%global ini_name 40-%{pecl_name}.ini
-%endif
-%global prever b1
-
-Name: %{?sub_prefix}php-pecl-radius
-Version: 1.4.0
-Release: 0.4.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Summary: Radius client library
-
-License: BSD
-Group: Development/Languages
-URL: http://pecl.php.net/package/radius
-Source0: http://pecl.php.net/get/radius-%{version}%{?prever}.tgz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
-BuildRequires: %{?scl_prefix}php-pear
-# Used by test suite
-BuildRequires: %{?scl_prefix}php-posix
-BuildRequires: %{?scl_prefix}php-sockets
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-Obsoletes: php54-pecl-%{pecl_name}
-Obsoletes: php54w-pecl-%{pecl_name}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name}
-Obsoletes: php55w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name}
-Obsoletes: php56w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name}
-Obsoletes: php70w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name}
-Obsoletes: php71w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name}
-Obsoletes: php72w-pecl-%{pecl_name}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-This package is based on the libradius of FreeBSD, with some modifications
-and extensions. This PECL provides full support for RADIUS authentication
-(RFC 2865) and RADIUS accounting (RFC 2866), works on Unix and on Windows.
-Its an easy way to authenticate your users against the user-database of your
-OS (for example against Windows Active-Directory via IAS).
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -qc
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-mv %{pecl_name}-%{version}%{?prever} NTS
-cd NTS
-
-extver=$(sed -n '/#define PHP_RADIUS_VERSION/{s/.* "//;s/".*$//;p}' php_radius.h)
-if test "x${extver}" != "x%{version}%{?prever}"; then
- : Error: Upstream version is ${extver}, expecting %{version}%{?prever}.
- exit 1
-fi
-cd ..
-
-cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# Install XML package description
-install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-# install config file
-install -Dpm644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -Dpm644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-cd NTS
-for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%check
-DEP=
-[ -f %{php_extdir}/posix.so ] && DEP="$DEP -d extension=posix.so"
-[ -f %{php_extdir}/sockets.so ] && DEP="$DEP -d extension=sockets.so"
-
-%if "%{php_version}" > "5.5"
-# used fake_server is not compatible with php 5.5
-# Deprecated: Non-static method xxx should not be called statically
-rm -f $(grep -l fake_server ?TS/tests/*phpt)
-%endif
-
-# simple module load test
-%{__php} --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for NTS extension
-cd NTS
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n $DEP -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
-
-%if %{with_zts}
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for ZTS extension
-cd ../ZTS
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n $DEP -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
-%endif
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.4.0-0.4.b1
-- rebuild for PHP 7.2.0beta1 new API
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-0.3.b1
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-0.2.b1
-- rebuild for PHP 7.1 new API version
-
-* Mon Feb 15 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-0.1.b1
-- Update to 1.4.0b1 (beta)
-
-* Mon Feb 15 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
-- Update to 1.3.0 (stable)
-
-* Sat Jun 20 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-6
-- allow build against rh-php56 (as more-php56)
-- drop runtime dependency on pear, new scriptlets
-- don't install/register tests
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.1.2-5.1
-- Fedora 21 SCL mass rebuild
-
-* Mon Aug 25 2014 Remi Collet <rcollet@redhat.com> - 1.1.2-5
-- improve SCL build
-
-* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 1.1.2-4
-- add numerical prefix to extension configuration file
-
-* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 1.1.2-3
-- allow SCL build
-
-* Sun Mar 16 2014 Remi Collet <remi@fedoraproject.org> - 1.2.7-2
-- run upstream test suite
-- install doc in pecl_docdir
-- install tests in pecl_testdir
-- add missing License file (extracted from headers)
-
-* Fri Jun 28 2013 Remi Collet <remi@fedoraproject.org> - 1.2.7-1
-- Update to 1.2.7
-
-* Thu Jun 20 2013 Remi Collet <remi@fedoraproject.org> - 1.2.6-1
-- Update to 1.2.6
-
-* Fri Nov 18 2011 Remi Collet <rpms@famillecollet.com> 1.2.5-14
-- also provides php-radius
-
-* Fri Nov 18 2011 Remi Collet <rpms@famillecollet.com> 1.2.5-12
-- php 5.4 build
-
-* Thu Oct 06 2011 Remi Collet <rpms@famillecollet.com> 1.2.5-11
-- ZTS extension
-- spec cleanups
-
-* Wed Jul 6 2011 Remi Collet <Fedora@FamilleCollet.com> - 1.2.5-11
-- fix php_zend_api usage, fix FTBFS #715846
-
-* Sat Oct 23 2010 Remi Collet <Fedora@FamilleCollet.com> - 1.2.5-10
-- add filter_provides to avoid private-shared-object-provides ncurses.so
-
-* Sat Aug 28 2010 Remi Collet <Fedora@FamilleCollet.com> - 1.2.5-9
-- clean define
-- use more macros
-- add simple load test in %%check
-
-* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.5-8
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
-
-* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> - 1.2.5-7
-- rebuild for new PHP 5.3.0 ABI (20090626)
-
-* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.5-6
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
-
-* Sat Apr 19 2008 Christopher Stone <chris.stone@gmail.com> 1.2.5-5
-- Fix Requires for post/postun sections (bz #442699)
-
-* Fri Feb 22 2008 Christopher Stone <chris.stone@gmail.com> 1.2.5-4
-- Properly register package
-
-* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.5-3
-- Autorebuild for GCC 4.3
-
-* Sun Sep 30 2007 Christopher Stone <chris.stone@gmail.com> 1.2.5-2
-- Update to new standards
-
-* Sat Sep 08 2007 Christopher Stone <chris.stone@gmail.com> 1.2.5-1
-- Upstream sync
-
-* Sun Mar 11 2007 Christopher Stone <chris.stone@gmail.com> 1.2.4-2
-- Use new ABI check for FC-6
-- Create directory to untar sources
-- Remove %%{release} from Provides
-
-* Sat Jul 01 2006 Christopher Stone <chris.stone@gmail.com> 1.2.4-1
-- Initial release
diff --git a/php-pecl-radius.spec b/php-pecl-radius.spec
index fa24376..4809ec9 100644
--- a/php-pecl-radius.spec
+++ b/php-pecl-radius.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-radius
#
-# Copyright (c) 2009-2017 Remi Collet
+# Copyright (c) 2009-2018 Remi Collet
# Copyright (c) 2006-2009 Christopher Stone
#
# License: MIT