summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-15 16:22:27 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-15 16:22:27 +0100
commitaa1329e62459554d0a5ed7ec9331dd3bcda1b42f (patch)
tree9ad64afa768505f79460e70f601e5018eec06699
parent706cd8c02463b1bc4a273a0ac6b73dcef92d4a79 (diff)
php-pecl-radius: 1.3.0 (stable)
-rw-r--r--REFLECTION35
-rw-r--r--php-pecl-radius.spec41
2 files changed, 53 insertions, 23 deletions
diff --git a/REFLECTION b/REFLECTION
index 5b2cf89..27079b7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,12 +1,18 @@
-Extension [ <persistent> extension #119 radius version 1.2.7 ] {
+Extension [ <persistent> extension #147 radius version 1.3.0 ] {
- - Constants [162] {
+ - Constants [187] {
Constant [ integer RADIUS_ACCESS_REQUEST ] { 1 }
Constant [ integer RADIUS_ACCESS_ACCEPT ] { 2 }
Constant [ integer RADIUS_ACCESS_REJECT ] { 3 }
Constant [ integer RADIUS_ACCOUNTING_REQUEST ] { 4 }
Constant [ integer RADIUS_ACCOUNTING_RESPONSE ] { 5 }
Constant [ integer RADIUS_ACCESS_CHALLENGE ] { 11 }
+ Constant [ integer RADIUS_DISCONNECT_REQUEST ] { 40 }
+ Constant [ integer RADIUS_DISCONNECT_ACK ] { 41 }
+ Constant [ integer RADIUS_DISCONNECT_NAK ] { 42 }
+ Constant [ integer RADIUS_COA_REQUEST ] { 43 }
+ Constant [ integer RADIUS_COA_ACK ] { 44 }
+ Constant [ integer RADIUS_COA_NAK ] { 45 }
Constant [ integer RADIUS_USER_NAME ] { 1 }
Constant [ integer RADIUS_USER_PASSWORD ] { 2 }
Constant [ integer RADIUS_CHAP_PASSWORD ] { 3 }
@@ -92,6 +98,22 @@ Extension [ <persistent> extension #119 radius version 1.2.7 ] {
Constant [ integer RADIUS_LOGIN_IPV6_HOST ] { 98 }
Constant [ integer RADIUS_FRAMED_IPV6_ROUTE ] { 99 }
Constant [ integer RADIUS_FRAMED_IPV6_POOL ] { 100 }
+ Constant [ integer RADIUS_ERROR_CAUSE ] { 101 }
+ Constant [ integer RADIUS_ERROR_CAUSE_RESIDUAL_SESSION_CONTEXT_REMOVED ] { 201 }
+ Constant [ integer RADIUS_ERROR_CAUSE_INVALID_EAP_PACKET ] { 202 }
+ Constant [ integer RADIUS_ERROR_CAUSE_UNSUPPORTED_ATTRIBUTE ] { 401 }
+ Constant [ integer RADIUS_ERROR_CAUSE_MISSING_ATTRIBUTE ] { 402 }
+ Constant [ integer RADIUS_ERROR_CAUSE_NAS_IDENTIFICATION_MISMATCH ] { 403 }
+ Constant [ integer RADIUS_ERROR_CAUSE_INVALID_REQUEST ] { 404 }
+ Constant [ integer RADIUS_ERROR_CAUSE_UNSUPPORTED_SERVICE ] { 405 }
+ Constant [ integer RADIUS_ERROR_CAUSE_UNSUPPORTED_EXCEPTION ] { 406 }
+ Constant [ integer RADIUS_ERROR_CAUSE_ADMINISTRATIVELY_PROHIBITED ] { 501 }
+ Constant [ integer RADIUS_ERROR_CAUSE_REQUEST_NOT_ROUTABLE ] { 502 }
+ Constant [ integer RADIUS_ERROR_CAUSE_SESSION_CONTEXT_NOT_FOUND ] { 503 }
+ Constant [ integer RADIUS_ERROR_CAUSE_SESSION_CONTEXT_NOT_REMOVABLE ] { 504 }
+ Constant [ integer RADIUS_ERROR_CAUSE_OTHER_PROXY_PROCESSING_ERROR ] { 505 }
+ Constant [ integer RADIUS_ERROR_CAUSE_RESOURCES_UNAVAILABLE ] { 506 }
+ Constant [ integer RADIUS_ERROR_CAUSE_REQUEST_INITIATED ] { 507 }
Constant [ integer RADIUS_ACCT_STATUS_TYPE ] { 40 }
Constant [ integer RADIUS_START ] { 1 }
Constant [ integer RADIUS_STOP ] { 2 }
@@ -162,6 +184,9 @@ Extension [ <persistent> extension #119 radius version 1.2.7 ] {
Constant [ integer RADIUS_MICROSOFT_MS_PRIMARY_NBNS_SERVER ] { 30 }
Constant [ integer RADIUS_MICROSOFT_MS_SECONDARY_NBNS_SERVER ] { 31 }
Constant [ integer RADIUS_MICROSOFT_MS_ARAP_CHALLENGE ] { 33 }
+ Constant [ integer RADIUS_OPTION_NONE ] { 0 }
+ Constant [ integer RADIUS_OPTION_TAGGED ] { 1 }
+ Constant [ integer RADIUS_OPTION_SALT ] { 2 }
Constant [ integer RADIUS_MPPE_KEY_LEN ] { 16 }
}
@@ -200,6 +225,10 @@ Extension [ <persistent> extension #119 radius version 1.2.7 ] {
}
Function [ <internal:radius> function radius_get_attr ] {
}
+ Function [ <internal:radius> function radius_get_tagged_attr_data ] {
+ }
+ Function [ <internal:radius> function radius_get_tagged_attr_tag ] {
+ }
Function [ <internal:radius> function radius_get_vendor_attr ] {
}
Function [ <internal:radius> function radius_cvt_addr ] {
@@ -208,6 +237,8 @@ Extension [ <persistent> extension #119 radius version 1.2.7 ] {
}
Function [ <internal:radius> function radius_cvt_string ] {
}
+ Function [ <internal:radius> function radius_salt_encrypt_attr ] {
+ }
Function [ <internal:radius> function radius_request_authenticator ] {
}
Function [ <internal:radius> function radius_server_secret ] {
diff --git a/php-pecl-radius.spec b/php-pecl-radius.spec
index 25b0c1a..e860fe7 100644
--- a/php-pecl-radius.spec
+++ b/php-pecl-radius.spec
@@ -20,12 +20,9 @@
%endif
%{?scl: %scl_package php-pecl-radius}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
-%global pecl_name radius
-%global with_zts 0%{?__ztsphp:1}
+%global pecl_name radius
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -33,8 +30,8 @@
%endif
Name: %{?sub_prefix}php-pecl-radius
-Version: 1.2.7
-Release: 6%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.3.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Radius client library
License: BSD
@@ -42,10 +39,6 @@ Group: Development/Languages
URL: http://pecl.php.net/package/radius
Source0: http://pecl.php.net/get/radius-%{version}.tgz
-# https://bugs.php.net/65156 ask license file
-# file created from the radius.c headers
-Source1: LICENSE
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -57,10 +50,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -92,22 +87,20 @@ and extensions. This PECL provides full support for RADIUS authentication
Its an easy way to authenticate your users against the user-database of your
OS (for example against Windows Active-Directory via IAS).
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -qc
-sed -e '/CREDITS/s/role="src"/role="doc"/' -i package.xml
-
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
mv %{pecl_name}-%{version} NTS
cd NTS
-cp %{SOURCE1} LICENSE
-
extver=$(sed -n '/#define PHP_RADIUS_VERSION/{s/.* "//;s/".*$//;p}' php_radius.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream version is ${extver}, expecting %{version}.
@@ -158,7 +151,7 @@ install -Dpm644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
cd NTS
-for i in LICENSE $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -202,6 +195,7 @@ REPORT_EXIT_STATUS=1 \
%endif
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -218,6 +212,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%clean
@@ -226,6 +221,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -239,6 +235,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Feb 15 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- Update to 1.3.0
+
* Sat Jun 20 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-6
- allow build against rh-php56 (as more-php56)
- drop runtime dependency on pear, new scriptlets