From 6173e6a9aa5f16ec710fa39808d3b77727e5af4f Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Sat, 10 May 2014 07:30:34 +0200
Subject: php-pecl-pthreads: 2.0.5 (stable)

---
 php-pecl-pthreads.spec | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)

diff --git a/php-pecl-pthreads.spec b/php-pecl-pthreads.spec
index 2c97e10..143c9b7 100644
--- a/php-pecl-pthreads.spec
+++ b/php-pecl-pthreads.spec
@@ -12,10 +12,15 @@
 %{!?__php:       %global __php       %{_bindir}/php}
 
 %global pecl_name pthreads
+%if "%{php_version}" < "5.6"
+%global ini_name  %{pecl_name}.ini
+%else
+%global ini_name  40-%{pecl_name}.ini
+%endif
 
 Summary:        Threading API
 Name:           %{?scl_prefix}php-pecl-%{pecl_name}
-Version:        2.0.4
+Version:        2.0.5
 Release:        1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
 License:        PHP
 Group:          Development/Languages
@@ -77,7 +82,7 @@ fi
 cd ..
 
 # Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
 ; Enable %{pecl_name} extension module
 extension=%{pecl_name}.so
 EOF
@@ -98,7 +103,7 @@ make -C %{pecl_name}-%{version} \
      install INSTALL_ROOT=%{buildroot}
 
 # install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
 
 # Install XML package description
 install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -151,11 +156,15 @@ rm -rf %{buildroot}
 %doc %{pecl_testdir}/%{pecl_name}
 %{pecl_xmldir}/%{name}.xml
 
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
 %{php_ztsextdir}/%{pecl_name}.so
 
 
 %changelog
+* Sat May 10 2014 Remi Collet <remi@fedoraproject.org> - 2.0.5-1
+- Update to 2.0.5 (stable)
+- add numerical prefix to extension configuration file
+
 * Sun Mar 30 2014 Remi Collet <remi@fedoraproject.org> - 2.0.4-1
 - Update to 2.0.4 (stable)
 
-- 
cgit