From 0d2ea15d4b79e24f3c9cd614baa74e57a784b908 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Mon, 7 Mar 2022 08:16:12 +0100
Subject: update to 3.20.0RC1

---
 PHPINFO                |  2 +-
 REFLECTION             | 26 +++++++++++++++++++++-----
 php-pecl-protobuf.spec |  7 +++++--
 3 files changed, 27 insertions(+), 8 deletions(-)

diff --git a/PHPINFO b/PHPINFO
index 904628e..5c7bb51 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
 
 protobuf
 
-Version => 3.19.4
+Version => 3.20.0RC1
 
 Directive => Local Value => Master Value
 protobuf.keep_descriptor_pool_after_request => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index f86e783..c817a6f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
+Extension [ <persistent> extension #120 protobuf version 3.20.0RC1 ] {
 
   - Dependencies {
     Dependency [ date (Optional) ]
@@ -62,8 +62,9 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
         Method [ <internal:protobuf, prototype ArrayAccess> public method offsetExists ] {
 
           - Parameters [1] {
-            Parameter #0 [ <required> $index ]
+            Parameter #0 [ <optional> $index = <default> ]
           }
+          - Return [ bool ]
         }
 
         Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
@@ -79,25 +80,29 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
             Parameter #0 [ <required> $index ]
             Parameter #1 [ <required> $newval ]
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype ArrayAccess> public method offsetUnset ] {
 
           - Parameters [1] {
-            Parameter #0 [ <required> $index ]
+            Parameter #0 [ <optional> $index = <default> ]
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype Countable> public method count ] {
 
           - Parameters [0] {
           }
+          - Return [ int ]
         }
 
         Method [ <internal:protobuf, prototype IteratorAggregate> public method getIterator ] {
 
           - Parameters [0] {
           }
+          - Return [ Traversable ]
         }
       }
     }
@@ -121,6 +126,7 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
 
           - Parameters [0] {
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype Iterator> public method current ] {
@@ -139,12 +145,14 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
 
           - Parameters [0] {
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype Iterator> public method valid ] {
 
           - Parameters [0] {
           }
+          - Return [ bool ]
         }
       }
     }
@@ -624,8 +632,9 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
         Method [ <internal:protobuf, prototype ArrayAccess> public method offsetExists ] {
 
           - Parameters [1] {
-            Parameter #0 [ <required> $index ]
+            Parameter #0 [ <optional> $index = <default> ]
           }
+          - Return [ bool ]
         }
 
         Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
@@ -641,25 +650,29 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
             Parameter #0 [ <required> $index ]
             Parameter #1 [ <required> $newval ]
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype ArrayAccess> public method offsetUnset ] {
 
           - Parameters [1] {
-            Parameter #0 [ <required> $index ]
+            Parameter #0 [ <optional> $index = <default> ]
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype Countable> public method count ] {
 
           - Parameters [0] {
           }
+          - Return [ int ]
         }
 
         Method [ <internal:protobuf, prototype IteratorAggregate> public method getIterator ] {
 
           - Parameters [0] {
           }
+          - Return [ Traversable ]
         }
       }
     }
@@ -683,6 +696,7 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
 
           - Parameters [0] {
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype Iterator> public method current ] {
@@ -701,12 +715,14 @@ Extension [ <persistent> extension #120 protobuf version 3.19.4 ] {
 
           - Parameters [0] {
           }
+          - Return [ void ]
         }
 
         Method [ <internal:protobuf, prototype Iterator> public method valid ] {
 
           - Parameters [0] {
           }
+          - Return [ bool ]
         }
       }
     }
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index a27b07c..fa843d0 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -17,8 +17,8 @@
 %global pecl_name   protobuf
 %global with_zts    0
 %global ini_name    40-%{pecl_name}.ini
-%global upstream_version 3.19.4
-#global upstream_prever  RC2
+%global upstream_version 3.20.0
+%global upstream_prever  RC1
 
 Summary:       Mechanism for serializing structured data
 Name:          %{?scl_prefix}php-pecl-%{pecl_name}
@@ -196,6 +196,9 @@ fi
 
 
 %changelog
+* Mon Mar  7 2022 Remi Collet <remi@remirepo.net> - 3.20.0~RC1-1
+- update to 3.20.0RC1
+
 * Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 3.19.4-1
 - update to 3.19.4
 
-- 
cgit