summaryrefslogtreecommitdiffstats
path: root/php-pecl-protobuf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-protobuf.spec')
-rw-r--r--php-pecl-protobuf.spec13
1 files changed, 12 insertions, 1 deletions
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 5931a3f..b761033 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -22,7 +22,7 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.11.0
+%global upstream_version 3.11.1
#global upstream_prever RC2
Summary: Mechanism for serializing structured data
@@ -33,6 +33,9 @@ License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: https://github.com/TeBoring/protobuf/commit/15dc0f40438599f20303dbcec77bce010af88270.patch
+Patch1: https://github.com/protocolbuffers/protobuf/commit/5b075fd0afe0e3df78ba12edb4074ccd5c131984.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.5.9
BuildRequires: %{?scl_prefix}php-pear
@@ -98,6 +101,9 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
+%patch0 -p5
+%patch1 -p5
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PROTOBUF_VERSION/{s/.* "//;s/".*$//;p}' protobuf.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -217,6 +223,11 @@ fi
%changelog
+* Tue Dec 3 2019 Remi Collet <remi@remirepo.net> - 3.11.1-1
+- update to 3.11.1
+- add patches for PHP 7.4 from
+ https://github.com/protocolbuffers/protobuf/pull/6968
+
* Tue Nov 26 2019 Remi Collet <remi@remirepo.net> - 3.11.0-1
- update to 3.11.0