summaryrefslogtreecommitdiffstats
path: root/php-pecl-protobuf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-protobuf.spec')
-rw-r--r--php-pecl-protobuf.spec10
1 files changed, 8 insertions, 2 deletions
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 3012f73..a5757dd 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -22,8 +22,8 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.7.1
-#global upstream_prever RC3
+%global upstream_version 3.8.0
+%global upstream_prever RC1
Summary: Mechanism for serializing structured data
Name: %{?sub_prefix}php-pecl-%{pecl_name}
@@ -33,6 +33,8 @@ License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source1: https://raw.githubusercontent.com/protocolbuffers/protobuf/v3.8.0-rc1/php/ext/google/protobuf/builtin_descriptors.inc
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.5.9
BuildRequires: %{?scl_prefix}php-pear
@@ -94,6 +96,8 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
+cp %{SOURCE1} .
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PROTOBUF_VERSION/{s/.* "//;s/".*$//;p}' protobuf.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -212,6 +216,8 @@ fi
%changelog
* Wed Mar 27 2019 Remi Collet <remi@remirepo.net> - 3.7.1-1
- update to 3.7.1
+- open https://github.com/protocolbuffers/protobuf/issues/6108
+ missing file in pecl archive
* Fri Mar 1 2019 Remi Collet <remi@remirepo.net> - 3.7.0-1
- update to 3.7.0 (GA)