summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION387
-rw-r--r--php-pecl-protobuf.spec30
3 files changed, 234 insertions, 185 deletions
diff --git a/PHPINFO b/PHPINFO
index 7974675..eeb5855 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
protobuf
-Version => 4.29.0RC1
+Version => 4.30.0RC1
Directive => Local Value => Master Value
protobuf.keep_descriptor_pool_after_request => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 5d79409..0830b92 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
+Extension [ <persistent> extension #97 protobuf version 4.30.0RC1 ] {
- Dependencies {
Dependency [ date (Optional) ]
@@ -2862,6 +2862,182 @@ Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
}
}
+ Class [ <internal:protobuf> class GPBMetadata\Google\Protobuf\Timestamp ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:protobuf> final class Google\Protobuf\Timestamp extends Google\Protobuf\Internal\Message ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [20] {
+ Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data = <default> ]
+ }
+ }
+
+ Method [ <internal:protobuf> public method getSeconds ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf> public method setSeconds ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:protobuf> public method getNanos ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf> public method setNanos ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:protobuf> public method fromDateTime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $datetime ]
+ }
+ }
+
+ Method [ <internal:protobuf> public method toDateTime ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method discardUnknownFields ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromString ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg = <default> ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFrom ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method readWrapperValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $field ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method writeWrapperValue ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $field ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method hasOneof ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $field ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method readOneof ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $field ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method writeOneof ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $field ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method whichOneof ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $field ]
+ }
+ }
+ }
+ }
+
Class [ <internal:protobuf> class GPBMetadata\Google\Protobuf\Type ] {
- Constants [0] {
@@ -2899,7 +3075,7 @@ Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
- Properties [0] {
}
- - Methods [26] {
+ - Methods [28] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- Parameters [1] {
@@ -2985,6 +3161,19 @@ Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
}
}
+ Method [ <internal:protobuf> public method getEdition ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf> public method setEdition ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
- Parameters [0] {
@@ -3420,7 +3609,7 @@ Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [26] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- Parameters [1] {
@@ -3493,6 +3682,19 @@ Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
}
}
+ Method [ <internal:protobuf> public method getEdition ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf> public method setEdition ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
- Parameters [0] {
@@ -3880,9 +4082,10 @@ Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
Class [ <internal:protobuf> class Google\Protobuf\Syntax ] {
- - Constants [2] {
+ - Constants [3] {
Constant [ public int SYNTAX_PROTO2 ] { 0 }
Constant [ public int SYNTAX_PROTO3 ] { 1 }
+ Constant [ public int SYNTAX_EDITIONS ] { 2 }
}
- Static properties [0] {
@@ -3911,182 +4114,6 @@ Extension [ <persistent> extension #91 protobuf version 4.29.0RC1 ] {
}
}
- Class [ <internal:protobuf> class GPBMetadata\Google\Protobuf\Timestamp ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:protobuf> static public method initOnce ] {
-
- - Parameters [0] {
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
- Class [ <internal:protobuf> final class Google\Protobuf\Timestamp extends Google\Protobuf\Internal\Message ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [20] {
- Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $data = <default> ]
- }
- }
-
- Method [ <internal:protobuf> public method getSeconds ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:protobuf> public method setSeconds ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $value ]
- }
- }
-
- Method [ <internal:protobuf> public method getNanos ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:protobuf> public method setNanos ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $value ]
- }
- }
-
- Method [ <internal:protobuf> public method fromDateTime ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $datetime ]
- }
- }
-
- Method [ <internal:protobuf> public method toDateTime ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method discardUnknownFields ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromString ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $data ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $arg = <default> ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFrom ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $data ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method readWrapperValue ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $field ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method writeWrapperValue ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $field ]
- Parameter #1 [ <required> $value ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method hasOneof ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $field ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method readOneof ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $field ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method writeOneof ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $field ]
- Parameter #1 [ <required> $value ]
- }
- }
-
- Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> protected method whichOneof ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $field ]
- }
- }
- }
- }
-
Class [ <internal:protobuf> class GPBMetadata\Google\Protobuf\Wrappers ] {
- Constants [0] {
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 00afc78..cdd0b8c 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-protobuf
#
-# Copyright (c) 2016-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2016-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -12,7 +12,7 @@
%global pecl_name protobuf
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 4.29.0
+%global upstream_version 4.30.0
%global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -161,6 +161,28 @@ done
%changelog
+* Wed Feb 5 2025 Remi Collet <remi@remirepo.net> - 4.30.0~RC1-1
+- update to 4.30.0RC1
+
+* Thu Jan 9 2025 Remi Collet <remi@remirepo.net> - 4.29.3-1
+- update to 4.29.3 (no change)
+
+* Wed Dec 18 2024 Remi Collet <remi@remirepo.net> - 4.29.2-1
+- update to 4.29.2 (no change)
+- re-license spec file to CECILL-2.1
+
+* Thu Dec 5 2024 Remi Collet <remi@remirepo.net> - 4.29.1-1
+- update to 4.29.1 (no change)
+
+* Thu Nov 28 2024 Remi Collet <remi@remirepo.net> - 4.29.0-1
+- update to 4.29.0
+
+* Tue Nov 19 2024 Remi Collet <remi@remirepo.net> - 4.29.0~RC3-1
+- update to 4.29.0RC3
+
+* Thu Oct 24 2024 Remi Collet <remi@remirepo.net> - 4.29.0~RC2-1
+- update to 4.29.0RC2 (no change)
+
* Tue Oct 1 2024 Remi Collet <remi@remirepo.net> - 4.29.0~RC1-1
- update to 4.29.0RC1