summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION343
-rw-r--r--php-pecl-protobuf.spec11
2 files changed, 274 insertions, 80 deletions
diff --git a/REFLECTION b/REFLECTION
index f28040d..af9e0d0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,32 @@
-Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
+Extension [ <persistent> extension #117 protobuf version 3.4.0 ] {
- - Classes [9] {
- Class [ <internal:protobuf> class Google\Protobuf\Internal\MapField implements ArrayAccess, Countable ] {
+ - Classes [14] {
+ Class [ <internal:protobuf> class Google\Protobuf\DescriptorPool ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:protobuf> static public method getGeneratedPool ] {
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:protobuf> public method getDescriptorByClassName ] {
+ }
+
+ Method [ <internal:protobuf> public method getEnumDescriptorByClassName ] {
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Descriptor ] {
- Constants [0] {
}
@@ -16,47 +41,73 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
}
- Methods [6] {
- Method [ <internal:protobuf, ctor> public method __construct ] {
+ Method [ <internal:protobuf> public method getClass ] {
}
- Method [ <internal:protobuf, prototype ArrayAccess> public method offsetExists ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $index ]
- }
+ Method [ <internal:protobuf> public method getFullName ] {
}
- Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
+ Method [ <internal:protobuf> public method getField ] {
+ }
- - Parameters [1] {
- Parameter #0 [ <required> $index ]
- }
+ Method [ <internal:protobuf> public method getFieldCount ] {
}
- Method [ <internal:protobuf, prototype ArrayAccess> public method offsetSet ] {
+ Method [ <internal:protobuf> public method getOneofDecl ] {
+ }
- - Parameters [2] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> $newval ]
- }
+ Method [ <internal:protobuf> public method getOneofDeclCount ] {
}
+ }
+ }
- Method [ <internal:protobuf, prototype ArrayAccess> public method offsetUnset ] {
+ Class [ <internal:protobuf> class Google\Protobuf\EnumDescriptor ] {
- - Parameters [1] {
- Parameter #0 [ <required> $index ]
- }
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:protobuf> public method getValue ] {
}
- Method [ <internal:protobuf, prototype Countable> public method count ] {
+ Method [ <internal:protobuf> public method getValueCount ] {
+ }
+ }
+ }
- - Parameters [0] {
- }
+ Class [ <internal:protobuf> class Google\Protobuf\EnumValueDescriptor ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:protobuf> public method getName ] {
+ }
+
+ Method [ <internal:protobuf> public method getNumber ] {
}
}
}
- Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\RepeatedField implements ArrayAccess, IteratorAggregate, Traversable, Countable ] {
+ Class [ <internal:protobuf> class Google\Protobuf\FieldDescriptor ] {
- Constants [0] {
}
@@ -70,11 +121,104 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
- Properties [0] {
}
- - Methods [8] {
- Method [ <internal:protobuf, ctor> public method __construct ] {
+ - Methods [7] {
+ Method [ <internal:protobuf> public method getName ] {
}
- Method [ <internal:protobuf> public method append ] {
+ Method [ <internal:protobuf> public method getNumber ] {
+ }
+
+ Method [ <internal:protobuf> public method getLabel ] {
+ }
+
+ Method [ <internal:protobuf> public method getType ] {
+ }
+
+ Method [ <internal:protobuf> public method isMap ] {
+ }
+
+ Method [ <internal:protobuf> public method getEnumType ] {
+ }
+
+ Method [ <internal:protobuf> public method getMessageType ] {
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\GPBType ] {
+
+ - Constants [18] {
+ Constant [ integer DOUBLE ] { 1 }
+ Constant [ integer FLOAT ] { 2 }
+ Constant [ integer INT64 ] { 3 }
+ Constant [ integer UINT64 ] { 4 }
+ Constant [ integer INT32 ] { 5 }
+ Constant [ integer FIXED64 ] { 6 }
+ Constant [ integer FIXED32 ] { 7 }
+ Constant [ integer BOOL ] { 8 }
+ Constant [ integer STRING ] { 9 }
+ Constant [ integer GROUP ] { 10 }
+ Constant [ integer MESSAGE ] { 11 }
+ Constant [ integer BYTES ] { 12 }
+ Constant [ integer UINT32 ] { 13 }
+ Constant [ integer ENUM ] { 14 }
+ Constant [ integer SFIXED32 ] { 15 }
+ Constant [ integer SFIXED64 ] { 16 }
+ Constant [ integer SINT32 ] { 17 }
+ Constant [ integer SINT64 ] { 18 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\DescriptorPool ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:protobuf> static public method getGeneratedPool ] {
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:protobuf> public method internalAddGeneratedFile ] {
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\MapField implements ArrayAccess, IteratorAggregate, Traversable, Countable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:protobuf, ctor> public method __construct ] {
}
Method [ <internal:protobuf, prototype ArrayAccess> public method offsetExists ] {
@@ -120,7 +264,7 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
}
}
- Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\RepeatedFieldIter implements Iterator, Traversable ] {
+ Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\MapFieldIter implements Iterator, Traversable ] {
- Constants [0] {
}
@@ -167,42 +311,6 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
}
}
- Class [ <internal:protobuf> class Google\Protobuf\Internal\GPBType ] {
-
- - Constants [18] {
- Constant [ integer DOUBLE ] { 1 }
- Constant [ integer FLOAT ] { 2 }
- Constant [ integer INT64 ] { 3 }
- Constant [ integer UINT64 ] { 4 }
- Constant [ integer INT32 ] { 5 }
- Constant [ integer FIXED64 ] { 6 }
- Constant [ integer FIXED32 ] { 7 }
- Constant [ integer BOOL ] { 8 }
- Constant [ integer STRING ] { 9 }
- Constant [ integer GROUP ] { 10 }
- Constant [ integer MESSAGE ] { 11 }
- Constant [ integer BYTES ] { 12 }
- Constant [ integer UINT32 ] { 13 }
- Constant [ integer ENUM ] { 14 }
- Constant [ integer SFIXED32 ] { 15 }
- Constant [ integer SFIXED64 ] { 16 }
- Constant [ integer SINT32 ] { 17 }
- Constant [ integer SINT64 ] { 18 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
Class [ <internal:protobuf> class Google\Protobuf\Internal\Message ] {
- Constants [0] {
@@ -227,10 +335,10 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
Method [ <internal:protobuf> public method mergeFromString ] {
}
- Method [ <internal:protobuf> public method jsonEncode ] {
+ Method [ <internal:protobuf> public method serializeToJsonString ] {
}
- Method [ <internal:protobuf> public method jsonDecode ] {
+ Method [ <internal:protobuf> public method mergeFromJsonString ] {
}
Method [ <internal:protobuf> public method mergeFrom ] {
@@ -250,7 +358,7 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
}
}
- Class [ <internal:protobuf> class Google\Protobuf\Internal\DescriptorPool ] {
+ Class [ <internal:protobuf> class Google\Protobuf\OneofDescriptor ] {
- Constants [0] {
}
@@ -258,21 +366,25 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
- Static properties [0] {
}
- - Static methods [1] {
- Method [ <internal:protobuf> static public method getGeneratedPool ] {
- }
+ - Static methods [0] {
}
- Properties [0] {
}
- - Methods [1] {
- Method [ <internal:protobuf> public method internalAddGeneratedFile ] {
+ - Methods [3] {
+ Method [ <internal:protobuf> public method getName ] {
+ }
+
+ Method [ <internal:protobuf> public method getField ] {
+ }
+
+ Method [ <internal:protobuf> public method getFieldCount ] {
}
}
}
- Class [ <internal:protobuf> class Google\Protobuf\Internal\Descriptor ] {
+ Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\RepeatedField implements ArrayAccess, IteratorAggregate, Traversable, Countable ] {
- Constants [0] {
}
@@ -286,11 +398,57 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
- Properties [0] {
}
- - Methods [0] {
+ - Methods [8] {
+ Method [ <internal:protobuf, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:protobuf> public method append ] {
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $newval ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
- Class [ <internal:protobuf> class Google\Protobuf\Internal\EnumDescriptor ] {
+ Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\RepeatedFieldIter implements Iterator, Traversable ] {
- Constants [0] {
}
@@ -304,7 +462,36 @@ Extension [ <persistent> extension #118 protobuf version 3.3.2 ] {
- Properties [0] {
}
- - Methods [0] {
+ - Methods [5] {
+ Method [ <internal:protobuf, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 5bd0451..ac73d04 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -21,8 +21,8 @@
Summary: Mechanism for serializing structured data
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 3.3.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.4.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -122,6 +122,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -140,6 +142,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -213,6 +217,9 @@ fi
%changelog
+* Thu Aug 17 2017 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- Update to 3.4.0
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 3.3.2-2
- rebuild for PHP 7.2.0beta1 new API