summaryrefslogtreecommitdiffstats
path: root/php-pecl-protobuf.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-08 17:52:44 +0200
committerRemi Collet <remi@remirepo.net>2021-06-08 17:52:44 +0200
commitcc284ad08eff3a8f80e65159aab779505716ab37 (patch)
treeb5de70b0c38007b293bc58b1756f488fbd7a1d2e /php-pecl-protobuf.spec
parentf68693127c212e0137f58ed590a09765a21f2a30 (diff)
update to 3.17.3
add patch for PHP 8.1 from https://github.com/protocolbuffers/protobuf/pull/8710
Diffstat (limited to 'php-pecl-protobuf.spec')
-rw-r--r--php-pecl-protobuf.spec14
1 files changed, 13 insertions, 1 deletions
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 31cf593..40fcd54 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -18,7 +18,7 @@
%global pecl_name protobuf
%global with_zts 0
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.17.2
+%global upstream_version 3.17.3
#global upstream_prever RC2
Summary: Mechanism for serializing structured data
@@ -29,6 +29,8 @@ License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: %{pecl_name}-php81.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -58,6 +60,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -82,6 +87,8 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
+%patch0 -p5 -b .php81
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PROTOBUF_VERSION/{s/.* "//;s/".*$//;p}' protobuf.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -201,6 +208,11 @@ fi
%changelog
+* Tue Jun 8 2021 Remi Collet <remi@remirepo.net> - 3.17.3-1
+- update to 3.17.3
+- add patch for PHP 8.1 from
+ https://github.com/protocolbuffers/protobuf/pull/8710
+
* Thu Jun 3 2021 Remi Collet <remi@remirepo.net> - 3.17.2-1
- update to 3.17.2 (no change)