summaryrefslogtreecommitdiffstats
path: root/php-pecl-protobuf.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-09-20 10:47:00 +0200
committerRemi Collet <remi@php.net>2024-09-20 10:47:00 +0200
commitb386f9f0f7d0fd45f2cdcfb485a8e767f15c2243 (patch)
tree2c00df25813d01eeb59c9782cf11406ac6673630 /php-pecl-protobuf.spec
parent6d427741f45460e6eea3a55878368c67bb3128f7 (diff)
update to 3.25.5v3
Diffstat (limited to 'php-pecl-protobuf.spec')
-rw-r--r--php-pecl-protobuf.spec41
1 files changed, 11 insertions, 30 deletions
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index fab6e8c..9d95252 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -12,7 +12,7 @@
%global pecl_name protobuf
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.25.3
+%global upstream_version 3.25.5
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -55,8 +55,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
-e '/utf8_range/s/role="doc"/role="src"/' \
- %{?_licensedir: -e '/LICENSE/s/role="doc"/role="src"/' } \
- %{!?_licensedir:-e '/LICENSE/s/role="src"/role="doc"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -90,32 +89,32 @@ EOF
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
%configure \
--enable-protobuf \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--enable-protobuf \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
-
%install
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -147,29 +146,8 @@ done
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/LICENSE*}
-%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
+%license %{sources}/LICENSE*
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -182,6 +160,9 @@ fi
%changelog
+* Fri Sep 20 2024 Remi Collet <remi@remirepo.net> - 3.25.5-1
+- update to 3.25.5
+
* Fri Feb 16 2024 Remi Collet <remi@remirepo.net> - 3.25.3-1
- update to 3.25.3 (no change)