summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-27 09:53:30 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-27 09:53:30 +0200
commite1b1ec15512da9b13fb12ff04b98e4cc840b65a1 (patch)
treedba2ae012f7609ed6b995adff0ee32a971f3ee34
php-pecl-protobuf: 3.1.0a1 (alpha, php 5 only, new package)
-rw-r--r--LICENSE42
-rw-r--r--Makefile4
-rw-r--r--REFLECTION345
-rw-r--r--php-pecl-protobuf.spec219
4 files changed, 610 insertions, 0 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..f028c82
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,42 @@
+This license applies to all parts of Protocol Buffers except the following:
+
+ - Atomicops support for generic gcc, located in
+ src/google/protobuf/stubs/atomicops_internals_generic_gcc.h.
+ This file is copyrighted by Red Hat Inc.
+
+ - Atomicops support for AIX/POWER, located in
+ src/google/protobuf/stubs/atomicops_internals_power.h.
+ This file is copyrighted by Bloomberg Finance LP.
+
+Copyright 2014, Google Inc. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+copyright notice, this list of conditions and the following disclaimer
+in the documentation and/or other materials provided with the
+distribution.
+ * Neither the name of Google Inc. nor the names of its
+contributors may be used to endorse or promote products derived from
+this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+Code generated by the Protocol Buffer compiler is owned by the owner
+of the input file used when generating it. This code is not
+standalone and requires a support library to be linked with it. This
+support library is itself covered by the above license.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..9383f89
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,345 @@
+Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
+
+ - Classes [8] {
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\MapField implements ArrayAccess, Countable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:protobuf, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $newval ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\RepeatedField implements ArrayAccess, Countable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:protobuf, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:protobuf> public method append ] {
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $newval ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\GPBType ] {
+
+ - Constants [18] {
+ Constant [ integer DOUBLE ] { 1 }
+ Constant [ integer FLOAT ] { 2 }
+ Constant [ integer INT64 ] { 3 }
+ Constant [ integer UINT64 ] { 4 }
+ Constant [ integer INT32 ] { 5 }
+ Constant [ integer FIXED64 ] { 6 }
+ Constant [ integer FIXED32 ] { 7 }
+ Constant [ integer BOOL ] { 8 }
+ Constant [ integer STRING ] { 9 }
+ Constant [ integer GROUP ] { 10 }
+ Constant [ integer MESSAGE ] { 11 }
+ Constant [ integer BYTES ] { 12 }
+ Constant [ integer UINT32 ] { 13 }
+ Constant [ integer ENUM ] { 14 }
+ Constant [ integer SFIXED32 ] { 15 }
+ Constant [ integer SFIXED64 ] { 16 }
+ Constant [ integer SINT32 ] { 17 }
+ Constant [ integer SINT64 ] { 18 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\Message ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:protobuf> public method encode ] {
+ }
+
+ Method [ <internal:protobuf> public method decode ] {
+ }
+
+ Method [ <internal:protobuf> protected method readOneof ] {
+ }
+
+ Method [ <internal:protobuf> protected method writeOneof ] {
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\DescriptorPool ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:protobuf> static public method getGeneratedPool ] {
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:protobuf> public method internalAddGeneratedFile ] {
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\Descriptor ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\EnumDescriptor ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:protobuf> class Google\Protobuf\Internal\GPBUtil ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [12] {
+ Method [ <internal:protobuf> static public method checkInt32 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkUint32 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkInt64 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkUint64 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkEnum ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkFloat ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkDouble ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkBool ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkString ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkBytes ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$val ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkMessage ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$val ]
+ Parameter #1 [ <required> $klass ]
+ }
+ }
+
+ Method [ <internal:protobuf> static public method checkRepeatedField ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> &$val ]
+ Parameter #1 [ <required> $type ]
+ Parameter #2 [ <optional> $klass ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
new file mode 100644
index 0000000..8abccad
--- /dev/null
+++ b/php-pecl-protobuf.spec
@@ -0,0 +1,219 @@
+# remirepo spec file for php-pecl-protobuf
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%scl_package php-pecl-protobuf
+%endif
+
+%global pecl_name protobuf
+%global with_zts 0
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+%global prever a1
+
+Summary: Mechanism for serializing structured data
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 3.1.0
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{prever}.tgz
+Source1: https://raw.githubusercontent.com/google/protobuf/master/LICENSE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: %{?scl_prefix}php-devel >= 5.5.9
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+Google's language-neutral, platform-neutral, extensible mechanism for
+serializing structured data.
+
+See: https://developers.google.com/protocol-buffers/
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version}%{prever} NTS
+cp %{SOURCE1} LICENSE
+
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_PROTOBUF_VERSION/{s/.* "//;s/".*$//;p}' protobuf.h)
+if test "x${extver}" != "x%{version}%{prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{prever}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Drop in the bit of configuration
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension = %{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --enable-protobuf \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --enable-protobuf \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Install the package XML file
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Test & Documentation
+cd NTS
+for i in $(grep 'role="test"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%endif
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+#doc #{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Sep 27 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-0.1.a1
+- initial package, version 3.1.0a1 (alpha)
+- open https://github.com/google/protobuf/issues/2185 - License
+- open https://github.com/google/protobuf/issues/2185 - ZTS build
+- open https://github.com/google/protobuf/issues/2185 - PHP 7
+