summaryrefslogtreecommitdiffstats
path: root/php-pecl-propro-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-propro-dev.spec')
-rw-r--r--php-pecl-propro-dev.spec18
1 files changed, 15 insertions, 3 deletions
diff --git a/php-pecl-propro-dev.spec b/php-pecl-propro-dev.spec
index 20453f1..f1ad826 100644
--- a/php-pecl-propro-dev.spec
+++ b/php-pecl-propro-dev.spec
@@ -1,4 +1,7 @@
-# spec file for php-pecl-propro
+# remirepo spec file for php-pecl-propro
+# with SCL stuff, from:
+#
+# Fedora spec file for php-pecl-propro
#
# Copyright (c) 2013-2015 Remi Collet
# License: CC-BY-SA
@@ -6,6 +9,14 @@
#
# Please, preserve the changelog entries
#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
%{?scl: %scl_package php-pecl-raphf}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?php_incldir: %global php_incldir %{_includedir}/php}
@@ -25,7 +36,7 @@
# cd propro; git checkout phpng; pecl package
Summary: Property proxy
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.1
Release: 0.1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
@@ -72,7 +83,7 @@ Obsoletes: php56w-pecl-%{pecl_name}
%description
A reusable split-off of pecl_http's property proxy API.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
%package devel
@@ -151,6 +162,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :