summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-pq.spec32
3 files changed, 17 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index c6fc36b..99996d6 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
pq
PQ Support => enabled
-Extension Version => 2.1.7
+Extension Version => 2.1.8
Used Library => Compiled => Linked
-libpq => 11.6 => 11.0.6
+libpq => 12.3 => 12.0.3
diff --git a/REFLECTION b/REFLECTION
index 4796430..e04749a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #110 pq version 2.1.7 ] {
+Extension [ <persistent> extension #117 pq version 2.1.8 ] {
- Dependencies {
Dependency [ raphf (Required) ]
diff --git a/php-pecl-pq.spec b/php-pecl-pq.spec
index 60c815e..03b7c90 100644
--- a/php-pecl-pq.spec
+++ b/php-pecl-pq.spec
@@ -11,6 +11,9 @@
%scl_package php-pecl-pq
%endif
+# Build using "--without tests" to disable tests
+%bcond_without tests
+
%global gh_commit e381164032a750583657e449875f62d52b7b6609
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner m6w6
@@ -19,18 +22,12 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name pq
#global prever RC1
-%if %{?runselftest}%{!?runselftest:1}
-# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
-%else
-# Build using "--with tests" to enable tests
-%global with_tests 0%{?_with_tests:1}
-%endif
+
%global ini_name 50-%{pecl_name}.ini
Summary: PostgreSQL client library (libpq) binding
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.1.7
+Version: 2.1.8
%if 0%{?gh_date:1}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -51,7 +48,7 @@ BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?sub_prefix}php-pecl-raphf-devel >= 1.1.0
-%if %{with_tests}
+%if %{with tests}
BuildRequires: postgresql-server
BuildRequires: postgresql-contrib
%endif
@@ -71,23 +68,19 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -231,7 +224,7 @@ OPT="-n"
--modules | grep %{pecl_name}
%endif
-%if %{with_tests}
+%if %{with tests}
RET=0
: Running a server
@@ -294,6 +287,9 @@ exit $RET
%changelog
+* Thu Sep 24 2020 Remi Collet <remi@remirepo.net> - 2.1.8-1
+- update to 2.1.8
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 2.1.7-1
- update to 2.1.7