summaryrefslogtreecommitdiffstats
path: root/php-pecl-pcov.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-pcov.spec')
-rw-r--r--php-pecl-pcov.spec18
1 files changed, 14 insertions, 4 deletions
diff --git a/php-pecl-pcov.spec b/php-pecl-pcov.spec
index d1001b5..2111fc0 100644
--- a/php-pecl-pcov.spec
+++ b/php-pecl-pcov.spec
@@ -8,20 +8,20 @@
#
%{?scl: %scl_package php-pecl-pcov}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name pcov
%global ini_name 40-%{pecl_name}.ini
Summary: Code coverage driver
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.9.0
+Version: 1.0.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -98,8 +98,13 @@ cat << 'EOF' | tee %{ini_name}
extension=%{pecl_name}.so
; Configuration
+
+; The recommended defaults for production should be:
+pcov.enabled = 0
+
+; The recommended defaults for development should be:
;pcov.enabled = 1
-;pcov.directory = ''
+;pcov.directory = /path/to/your/source/directory
;pcov.exclude = ''
;pcov.initial.memory = 65536
;pcov.initial.files = 64
@@ -220,5 +225,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Jan 30 2019 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0 (stable)
+- raise dependency on PHP 7.1
+- switch to production recommended configuration
+
* Tue Jan 22 2019 Remi Collet <remi@remirepo.net> - 0.9.0-1
- initial package, version 0.9.0 (beta)