summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-30 14:14:40 +0100
committerRemi Collet <remi@remirepo.net>2019-01-30 14:14:40 +0100
commit1cfac57b0cbad9614e1c07645af6b69707a8398e (patch)
treec5e4bc244bf947fd27de100541360cc20541e723
parent50f3263a8bc0440387cfd6a4e4e301bdbd6d709d (diff)
update to 1.0.0 (stable)
raise dependency on PHP 7.1 switch to production recommended configuration
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION9
-rw-r--r--php-pecl-pcov.spec18
3 files changed, 21 insertions, 9 deletions
diff --git a/PHPINFO b/PHPINFO
index d519aed..e3b77b4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,8 @@
pcov
-PCOV support => Enabled
+PCOV support => Disabled
+PCOV version => 1.0.0
pcov.directory => auto
pcov.exclude => none
pcov.initial.memory => 65336 bytes
diff --git a/REFLECTION b/REFLECTION
index 2558a79..9fafcdf 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #126 pcov version 0.9.0 ] {
+Extension [ <persistent> extension #126 pcov version 1.0.0 ] {
- Dependencies {
Dependency [ pcre (Required) ]
@@ -6,7 +6,7 @@ Extension [ <persistent> extension #126 pcov version 0.9.0 ] {
- INI {
Entry [ pcov.enabled <SYSTEM> ]
- Current = '1'
+ Current = '0'
}
Entry [ pcov.directory <PERDIR,SYSTEM> ]
Current = ''
@@ -22,10 +22,11 @@ Extension [ <persistent> extension #126 pcov version 0.9.0 ] {
}
}
- - Constants [3] {
+ - Constants [4] {
Constant [ integer pcov\all ] { 0 }
Constant [ integer pcov\inclusive ] { 1 }
Constant [ integer pcov\exclusive ] { 2 }
+ Constant [ string pcov\version ] { 1.0.0 }
}
- Functions {
@@ -52,7 +53,7 @@ Extension [ <persistent> extension #126 pcov version 0.9.0 ] {
Parameter #0 [ <optional> boolean $files ]
}
}
- Function [ <internal:pcov> function pcov\includes ] {
+ Function [ <internal:pcov> function pcov\waiting ] {
- Parameters [0] {
}
diff --git a/php-pecl-pcov.spec b/php-pecl-pcov.spec
index d1001b5..2111fc0 100644
--- a/php-pecl-pcov.spec
+++ b/php-pecl-pcov.spec
@@ -8,20 +8,20 @@
#
%{?scl: %scl_package php-pecl-pcov}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name pcov
%global ini_name 40-%{pecl_name}.ini
Summary: Code coverage driver
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.9.0
+Version: 1.0.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -98,8 +98,13 @@ cat << 'EOF' | tee %{ini_name}
extension=%{pecl_name}.so
; Configuration
+
+; The recommended defaults for production should be:
+pcov.enabled = 0
+
+; The recommended defaults for development should be:
;pcov.enabled = 1
-;pcov.directory = ''
+;pcov.directory = /path/to/your/source/directory
;pcov.exclude = ''
;pcov.initial.memory = 65536
;pcov.initial.files = 64
@@ -220,5 +225,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Jan 30 2019 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0 (stable)
+- raise dependency on PHP 7.1
+- switch to production recommended configuration
+
* Tue Jan 22 2019 Remi Collet <remi@remirepo.net> - 0.9.0-1
- initial package, version 0.9.0 (beta)