summaryrefslogtreecommitdiffstats
path: root/php-pecl-parle.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-parle.spec')
-rw-r--r--php-pecl-parle.spec12
1 files changed, 11 insertions, 1 deletions
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index c48a380..5b7ac4a 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -24,12 +24,14 @@
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.8.2
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: %{pecl_name}-php81.patch
+
BuildRequires: make
%if 0%{?rhel} == 7 && 0%{?dtsversion} == 0
# Always use DTS as c++14 is required
@@ -74,6 +76,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -103,6 +108,7 @@ mv NTS/lib/parsertl14/parsertl/licence_1_0.txt NTS/LICENSE.parsertl14
%endif
cd NTS
+%patch0 -p1 -b .php81
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
@@ -234,6 +240,10 @@ fi
######### TODO : use --enable-parle-utf32 ?
%changelog
+* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 0.8.2-2
+- add patch for PHP 8.1 from
+ https://github.com/weltling/parle/pull/28
+
* Mon Jan 18 2021 Remi Collet <remi@remirepo.net> - 0.8.2-1
- update to 0.8.2
- drop patches merged upstream