summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION51
-rw-r--r--php-pecl-parle.spec54
3 files changed, 64 insertions, 43 deletions
diff --git a/PHPINFO b/PHPINFO
index 1960e9c..8610ac8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
parle
Lexing and parsing support => enabled
-Parle version => 0.8.3
+Parle version => 0.8.4
Parle internal UTF-32 => no
diff --git a/REFLECTION b/REFLECTION
index 6e0a060..1d8ccfe 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 parle version 0.8.3 ] {
+Extension [ <persistent> extension #122 parle version 0.8.4 ] {
- Constants [1] {
Constant [ bool Parle\INTERNAL_UTF32 ] { }
@@ -259,7 +259,7 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
Property [ public $reduceId = 0 ]
}
- - Methods [16] {
+ - Methods [18] {
Method [ <internal:parle> public method token ] {
- Parameters [1] {
@@ -335,6 +335,14 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Return [ string ]
}
+ Method [ <internal:parle> public method sigilName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> int $idx = <default> ]
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:parle> public method advance ] {
- Parameters [0] {
@@ -375,6 +383,13 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
Parameter #0 [ <required> int $tok ]
}
}
+
+ Method [ <internal:parle> public method sigilCount ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
}
}
@@ -402,7 +417,7 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
Property [ public $reduceId = 0 ]
}
- - Methods [16] {
+ - Methods [18] {
Method [ <internal:parle> public method token ] {
- Parameters [1] {
@@ -478,6 +493,14 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Return [ string ]
}
+ Method [ <internal:parle> public method sigilName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> int $idx = <default> ]
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:parle> public method advance ] {
- Parameters [0] {
@@ -518,6 +541,13 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
Parameter #0 [ <required> int $tok ]
}
}
+
+ Method [ <internal:parle> public method sigilCount ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
}
}
@@ -568,8 +598,8 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -586,6 +616,7 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -659,8 +690,8 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -677,6 +708,7 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -750,8 +782,8 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -768,6 +800,7 @@ Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index 232046f..8f8744e 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-parle
#
-# Copyright (c) 2017-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2017-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -11,10 +11,7 @@
%undefine _strict_symbol_defs_build
%bcond_without tests
-%if 0%{?scl:1}
-%scl_package php-pecl-parle
-%global sub_prefix %{scl_prefix}
-%endif
+%{?scl:%scl_package php-pecl-parle}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name parle
@@ -22,11 +19,11 @@
%global ini_name 40-%{pecl_name}.ini
Summary: Parsing and lexing
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.8.3
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.8.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
-License: BSD and Boost
+License: BSD-2-Clause AND BSL-1.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -40,7 +37,7 @@ BuildRequires: devtoolset-8-toolchain
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?dtsprefix}libstdc++-devel
-BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -57,22 +54,9 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
Obsoletes: %{name}-devel < %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
With Parle, it is possible to implement lexing and parsing in PHP
@@ -95,8 +79,8 @@ sed -e '/tests/s/role="test"/role="src"/'\
%if 0%{?_licensedir:1}
sed -e '/LICENSE/s/role="doc"/role="src"/;/licence/s/role="doc"/role="src"/' \
-i package.xml
-mv NTS/lib/lexertl14/lexertl/licence_1_0.txt NTS/LICENSE.lexert14
-mv NTS/lib/parsertl14/parsertl/licence_1_0.txt NTS/LICENSE.parsertl14
+mv NTS/lib/parsertl14/include/parsertl/licence_1_0.txt NTS/LICENSE.lexert14
+mv NTS/lib/lexertl14/include/lexertl/licence_1_0.txt NTS/LICENSE.parsertl14
%endif
cd NTS
@@ -132,13 +116,13 @@ make %{?_smp_mflags}
}
cd NTS
-%{_bindir}/phpize
-peclbuild %{_bindir}/php-config
+%{__phpize}
+peclbuild %{__phpconfig}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
-peclbuild %{_bindir}/zts-php-config
+%{__ztsphpize}
+peclbuild %{__ztsphpconfig}
%endif
@@ -173,11 +157,11 @@ export REPORT_EXIT_STATUS=1
cd NTS
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with tests}
: Upstream test suite
-make test "TESTS=--show-diff"
+make test "TESTS=--show-diff %{?_smp_mflags}"
%endif
%if %{with_zts}
@@ -185,11 +169,11 @@ cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with tests}
: Upstream test suite
-make test "TESTS=--show-diff"
+make test "TESTS=--show-diff %{?_smp_mflags}"
%endif
%endif
@@ -230,6 +214,10 @@ fi
######### TODO : use --enable-parle-utf32 ?
%changelog
+* Sun May 14 2023 Remi Collet <remi@remirepo.net> - 0.8.4-1
+- update to 0.8.4
+- raise dependency on PHP 7.4
+
* Sat Apr 16 2022 Remi Collet <remi@remirepo.net> - 0.8.3-1
- update to 0.8.3
- drop patch merged upstream