summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION92
-rw-r--r--php-pecl-parallel.spec9
3 files changed, 93 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index 71b19f4..b527b13 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
parallel
parallel support => enabled
-parallel version => 0.0.1dev
+parallel version => 0.8.0
diff --git a/REFLECTION b/REFLECTION
index b030b5c..1292c53 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #15 parallel version 0.0.1dev ] {
+Extension [ <persistent> extension #126 parallel version 0.8.0 ] {
- - Classes [3] {
+ - Classes [4] {
Class [ <internal:parallel> final class parallel\Runtime ] {
- Constants [0] {
@@ -15,7 +15,7 @@ Extension [ <persistent> extension #15 parallel version 0.0.1dev ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:parallel, ctor> public method __construct ] {
}
@@ -24,10 +24,13 @@ Extension [ <persistent> extension #15 parallel version 0.0.1dev ] {
Method [ <internal:parallel> public method close ] {
}
+
+ Method [ <internal:parallel> public method kill ] {
+ }
}
}
- Class [ <internal:parallel> final class parallel\Future ] {
+ Class [ <internal:parallel> class parallel\Exception extends ErrorException implements Throwable ] {
- Constants [0] {
}
@@ -38,16 +41,93 @@ Extension [ <persistent> extension #15 parallel version 0.0.1dev ] {
- Static methods [0] {
}
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $severity ]
+ }
+
+ - Methods [11] {
+ Method [ <internal:Core, inherits ErrorException, ctor> public method __construct ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $severity ]
+ Parameter #3 [ <optional> $filename ]
+ Parameter #4 [ <optional> $lineno ]
+ Parameter #5 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ErrorException> final public method getSeverity ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:parallel> final class parallel\Future ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:parallel> static public method select ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array &$resolving ]
+ Parameter #1 [ <required> array &$resolved ]
+ Parameter #2 [ <required> array &$errored ]
+ Parameter #3 [ <optional> array &$timedout ]
+ Parameter #4 [ <optional> integer $timeout ]
+ }
+ }
+ }
+
- Properties [0] {
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:parallel> public method value ] {
}
+
+ Method [ <internal:parallel> public method done ] {
+ }
}
}
- Class [ <internal:parallel> class parallel\Exception extends ErrorException implements Throwable ] {
+ Class [ <internal:parallel> class parallel\TimeoutException extends parallel\Exception implements Throwable ] {
- Constants [0] {
}
diff --git a/php-pecl-parallel.spec b/php-pecl-parallel.spec
index 155d6c6..410a846 100644
--- a/php-pecl-parallel.spec
+++ b/php-pecl-parallel.spec
@@ -13,8 +13,8 @@
Summary: Parallel concurrency API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.0.1
-Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.8.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%%{pecl_name}-%{version}.tgz
@@ -55,7 +55,7 @@ Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%description
-A succint parallel concurrency API for PHP 7.
+A succinct parallel concurrency API for PHP 7.
This extension is only available for PHP in ZTS mode.
@@ -164,6 +164,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Feb 18 2019 Remi Collet <remi@remirepo.Net> - 0.8.0-1
+- update to 0.8.0 (beta)
+
* Tue Feb 12 2019 Remi Collet <remi@remirepo.Net> - 0.0.1-0
- initial package
- test build for upcoming version 0.0.1 (beta)