summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION61
-rw-r--r--php-pecl-parallel.spec9
3 files changed, 66 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index 43cc56a..c5bff55 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
parallel
parallel support => enabled
-parallel version => 1.1.2
+parallel version => 1.1.3
diff --git a/REFLECTION b/REFLECTION
index 26d873d..a877e1d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #127 parallel version 1.1.2 ] {
+Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
- Functions {
Function [ <internal:parallel> function parallel\bootstrap ] {
@@ -23,7 +23,7 @@ Extension [ <persistent> extension #127 parallel version 1.1.2 ] {
}
}
- - Classes [36] {
+ - Classes [37] {
Class [ <internal:parallel> class parallel\Error extends Error implements Throwable ] {
- Constants [0] {
@@ -366,6 +366,63 @@ Extension [ <persistent> extension #127 parallel version 1.1.2 ] {
}
}
+ Class [ <internal:parallel> class parallel\Runtime\Error\IllegalVariable extends parallel\Runtime\Error implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Error, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Error> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:parallel> class parallel\Runtime\Error\IllegalParameter extends parallel\Runtime\Error implements Throwable ] {
- Constants [0] {
diff --git a/php-pecl-parallel.spec b/php-pecl-parallel.spec
index 9ff0f95..56d869d 100644
--- a/php-pecl-parallel.spec
+++ b/php-pecl-parallel.spec
@@ -13,7 +13,7 @@
Summary: Parallel concurrency API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.1.2
+Version: 1.1.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
@@ -40,11 +40,11 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -168,6 +168,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Aug 14 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+
* Thu Jun 13 2019 Remi Collet <remi@remirepo.net> - 1.1.2-1
- update to 1.1.2