summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION3
-rw-r--r--php-pecl-operator.spec133
5 files changed, 154 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..59e1da3
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,5 @@
+
+operator
+
+operator support => enabled
+operator version => 0.5.0
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..a7b31bf
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,3 @@
+Extension [ <persistent> extension #97 operator version 0.5.0 ] {
+}
+
diff --git a/php-pecl-operator.spec b/php-pecl-operator.spec
new file mode 100644
index 0000000..7ad8b64
--- /dev/null
+++ b/php-pecl-operator.spec
@@ -0,0 +1,133 @@
+# remirepo spec file for php-pecl-operator
+#
+# SPDX-FileCopyrightText: Copyright 2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+#
+# Please, preserve the changelog entries
+#
+%{?scl:%scl_package php-pecl-operator}
+
+%bcond_without tests
+
+%global pecl_name operator
+%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+
+
+Summary: Operator overloading for Objects
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.5.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP-3.01
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 8.2
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+
+%description
+Operator overloading for:
++, -, *, /, %, **, <<, >>, ., |, &, ^, ~, ++, --,
+=, +=, -=, *=, /=, %=, **=, <<=, >>=, .=, |=, &=, ^=,
+==, !=, <>, ===, !==, <, <=, >, >=, and <=> operators.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
+ -i package.xml
+
+cd %{sources}
+# Sanity check, really often broken
+extver=$(sed -n '/# define PHP_OPERATOR_VERSION/{s/.* "//;s/".*$//;p}' operator.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
+
+%configure \
+ --enable-operator \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
+
+%make_build
+
+
+%install
+%{?dtsenable}
+
+cd %{sources}
+%make_install
+
+# install config file
+install -D -m 644 ../%{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 ../package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Documentation
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd %{sources}
+
+# Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with tests}
+: Upstream test suite for NTS extension
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php -q -P --show-diff
+%endif
+
+
+%files
+%license %{sources}/LICENSE
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+
+%changelog
+* Thu Feb 27 2025 Remi Collet <remi@remirepo.net> - 0.5.0-1
+- initial package (version 0.5.0, beta)
+