summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-12 07:21:17 +0100
committerRemi Collet <remi@remirepo.net>2017-12-12 07:21:17 +0100
commit7b0637a5e44bccf5fab9c563c267836d7b963414 (patch)
treee11e798c7cdadeb31bdaa007f3ea97814ba93d9e
parent79c9b7dd2266562d2b281d4afea28f459511d415 (diff)
v0.1.0RC2
-rw-r--r--REFLECTION156
-rw-r--r--php-pecl-opencensus.spec16
2 files changed, 144 insertions, 28 deletions
diff --git a/REFLECTION b/REFLECTION
index 52c247c..251be69 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 opencensus version 0.0.4 ] {
+Extension [ <persistent> extension #117 opencensus version 0.1.0RC2 ] {
- Functions {
Function [ <internal:opencensus> function opencensus_version ] {
@@ -40,31 +40,43 @@ Extension [ <persistent> extension #115 opencensus version 0.0.4 ] {
}
Function [ <internal:opencensus> function opencensus_trace_context ] {
}
- Function [ <internal:opencensus> function opencensus_trace_add_label ] {
+ Function [ <internal:opencensus> function opencensus_trace_add_attribute ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> string $key ]
Parameter #1 [ <required> string $value ]
+ Parameter #2 [ <optional> array $options ]
}
}
- Function [ <internal:opencensus> function opencensus_trace_add_root_label ] {
+ Function [ <internal:opencensus> function opencensus_trace_add_annotation ] {
- Parameters [2] {
- Parameter #0 [ <required> string $key ]
- Parameter #1 [ <required> string $value ]
+ Parameter #0 [ <required> string $description ]
+ Parameter #1 [ <optional> array $options ]
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_trace_add_link ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $traceId ]
+ Parameter #1 [ <required> string $spanId ]
+ Parameter #2 [ <optional> array $options ]
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_trace_add_message_event ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $type ]
+ Parameter #1 [ <required> string $id ]
+ Parameter #2 [ <optional> array $options ]
}
}
}
- - Classes [2] {
- Class [ <internal:opencensus> class OpenCensus\Trace\Span ] {
+ - Classes [5] {
+ Class [ <internal:opencensus> class OpenCensus\Trace\Ext\Span ] {
- - Constants [5] {
- Constant [ integer SPAN_KIND_UNKNOWN ] { 0 }
- Constant [ integer SPAN_KIND_CLIENT ] { 1 }
- Constant [ integer SPAN_KIND_SERVER ] { 2 }
- Constant [ integer SPAN_KIND_PRODUCER ] { 3 }
- Constant [ integer SPAN_KIND_CONSUMER ] { 4 }
+ - Constants [0] {
}
- Static properties [0] {
@@ -73,18 +85,19 @@ Extension [ <persistent> extension #115 opencensus version 0.0.4 ] {
- Static methods [0] {
}
- - Properties [8] {
+ - Properties [9] {
Property [ <default> protected $name ]
Property [ <default> protected $spanId ]
Property [ <default> protected $parentSpanId ]
Property [ <default> protected $startTime ]
Property [ <default> protected $endTime ]
- Property [ <default> protected $kind ]
- Property [ <default> protected $labels ]
- Property [ <default> protected $backtrace ]
+ Property [ <default> protected $attributes ]
+ Property [ <default> protected $stackTrace ]
+ Property [ <default> protected $links ]
+ Property [ <default> protected $timeEvents ]
}
- - Methods [9] {
+ - Methods [11] {
Method [ <internal:opencensus, ctor> public method __construct ] {
- Parameters [1] {
@@ -92,6 +105,9 @@ Extension [ <persistent> extension #115 opencensus version 0.0.4 ] {
}
}
+ Method [ <internal:opencensus, dtor> public method __destruct ] {
+ }
+
Method [ <internal:opencensus> public method name ] {
}
@@ -101,7 +117,7 @@ Extension [ <persistent> extension #115 opencensus version 0.0.4 ] {
Method [ <internal:opencensus> public method parentSpanId ] {
}
- Method [ <internal:opencensus> public method labels ] {
+ Method [ <internal:opencensus> public method attributes ] {
}
Method [ <internal:opencensus> public method startTime ] {
@@ -110,15 +126,18 @@ Extension [ <persistent> extension #115 opencensus version 0.0.4 ] {
Method [ <internal:opencensus> public method endTime ] {
}
- Method [ <internal:opencensus> public method backtrace ] {
+ Method [ <internal:opencensus> public method stackTrace ] {
}
- Method [ <internal:opencensus> public method kind ] {
+ Method [ <internal:opencensus> public method links ] {
+ }
+
+ Method [ <internal:opencensus> public method timeEvents ] {
}
}
}
- Class [ <internal:opencensus> class OpenCensus\Trace\Context ] {
+ Class [ <internal:opencensus> class OpenCensus\Trace\Ext\SpanContext ] {
- Constants [0] {
}
@@ -149,6 +168,97 @@ Extension [ <persistent> extension #115 opencensus version 0.0.4 ] {
}
}
}
+
+ Class [ <internal:opencensus> class OpenCensus\Trace\Ext\Annotation ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> protected $description ]
+ Property [ <default> protected $time ]
+ Property [ <default> protected $options ]
+ }
+
+ - Methods [3] {
+ Method [ <internal:opencensus> public method description ] {
+ }
+
+ Method [ <internal:opencensus> public method time ] {
+ }
+
+ Method [ <internal:opencensus> public method options ] {
+ }
+ }
+ }
+
+ Class [ <internal:opencensus> class OpenCensus\Trace\Ext\Link ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> protected $traceId ]
+ Property [ <default> protected $spanId ]
+ Property [ <default> protected $options ]
+ }
+
+ - Methods [3] {
+ Method [ <internal:opencensus> public method traceId ] {
+ }
+
+ Method [ <internal:opencensus> public method spanId ] {
+ }
+
+ Method [ <internal:opencensus> public method options ] {
+ }
+ }
+ }
+
+ Class [ <internal:opencensus> class OpenCensus\Trace\Ext\MessageEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $type ]
+ Property [ <default> protected $id ]
+ Property [ <default> protected $time ]
+ Property [ <default> protected $options ]
+ }
+
+ - Methods [4] {
+ Method [ <internal:opencensus> public method type ] {
+ }
+
+ Method [ <internal:opencensus> public method id ] {
+ }
+
+ Method [ <internal:opencensus> public method time ] {
+ }
+
+ Method [ <internal:opencensus> public method options ] {
+ }
+ }
+ }
}
}
diff --git a/php-pecl-opencensus.spec b/php-pecl-opencensus.spec
index aac50f7..b6db1dd 100644
--- a/php-pecl-opencensus.spec
+++ b/php-pecl-opencensus.spec
@@ -20,14 +20,17 @@
%global ini_name 40-%{pecl_name}.ini
%endif
+%global upstream_version 0.1.0
+%global upstream_prever RC2
+
Summary: A stats collection and distributed tracing framework
Name: %{?sub_prefix}php-pecl-opencensus
-Version: 0.0.4
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -81,7 +84,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-mv %{pecl_name}-%{version} NTS
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -92,8 +95,8 @@ cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_OPENCENSUS_VERSION/{s/.* "//;s/".*$//;p}' php_opencensus.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}.
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
fi
cd ..
@@ -224,6 +227,9 @@ fi
%changelog
+* Tue Dec 12 2017 Remi Collet <remi@remirepo.net> - 0.1.0~RC2-1
+- Update to 0.1.0RC2 (devel)
+
* Sat Oct 21 2017 Remi Collet <remi@remirepo.net> - 0.0.4-1
- Update to 0.0.4 (devel)