summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-12 18:35:24 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-12 18:35:24 +0100
commitcf0badf86c347bdd1589e5513b6c7da6c6352a25 (patch)
tree579ff00c9f41bcd101f7571c73501cd684f1a6a0
parent896f022873a5956d7ba3d12cdd7a2e45e8d63e8f (diff)
php-pecl-oci8: 2.0.10
-rw-r--r--php-pecl-oci8.spec34
1 files changed, 25 insertions, 9 deletions
diff --git a/php-pecl-oci8.spec b/php-pecl-oci8.spec
index afa90eb..fff9523 100644
--- a/php-pecl-oci8.spec
+++ b/php-pecl-oci8.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-oci8
+# remirepo spec file for php-pecl-oci8
#
# Copyright (c) 2014-2015 Remi Collet
# License: CC-BY-SA
@@ -30,8 +30,8 @@
Summary: Extension for Oracle Database
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.8
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.0.10
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -49,8 +49,6 @@ BuildRequires: oracle-instantclient-devel >= %{oraclever}
BuildRequires: systemtap-sdt-devel
%endif
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
# Should requires libclntsh.so.12.1 but it's not provided by Oracle RPM.
@@ -98,11 +96,13 @@ in the database installation, or in the free Oracle Instant Client
available from Oracle.
Notice:
-- php-oci8 provides oci8 and pdo_oci extensions from php sources.
+- %{?scl_prefix}php-oci8 provides oci8 and pdo_oci extensions from php sources.
- %name only provides oci8 extension.
Documentation is at http://php.net/oci8
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
%prep
%setup -qc
@@ -195,7 +195,11 @@ export PHP_DTRACE=yes
peclconf() {
%configure \
+%ifarch x86_64
--with-oci8=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
+%else
+ --with-oci8=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
+%endif
--with-php-config=$1
}
@@ -266,12 +270,20 @@ make test
%endif
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
@@ -295,6 +307,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Dec 12 2015 Remi Collet <remi@fedoraproject.org> - 2.0.10-1
+- Update to 2.0.10
+- drop runtime dependency on pear, new scriptlets
+
* Mon Sep 1 2014 Remi Collet <remi@fedoraproject.org> - 2.0.8-2
- fix SCL build