summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-18 15:07:33 +0200
committerRemi Collet <remi@remirepo.net>2021-09-18 15:07:33 +0200
commit2efbf772ada972f327e6e63a754d8384dd14f405 (patch)
tree3ea6a6115db2e9ffd963078acb6fa3f267b7f33c
parente002c6a29a4fe7bafc02cf62276aaaba064c389d (diff)
update to 3.5.1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION61
-rw-r--r--php-pecl-nsq.spec50
3 files changed, 81 insertions, 32 deletions
diff --git a/PHPINFO b/PHPINFO
index e33ea9c..7ed4108 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
nsq
nsq support => enabled
-version => 3.5.0
+version => 3.5.1
author => zhenyu.wu[email:wuzhenyu@kuangjue.com]
diff --git a/REFLECTION b/REFLECTION
index caea3c2..0c21953 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,10 +1,10 @@
-Extension [ <persistent> extension #124 nsq version 3.5.0 ] {
+Extension [ <persistent> extension #124 nsq version 3.5.1 ] {
- Dependencies {
Dependency [ json (Required) ]
}
- - Classes [3] {
+ - Classes [4] {
Class [ <internal:nsq> class Nsq ] {
- Constants [0] {
@@ -141,6 +141,63 @@ Extension [ <persistent> extension #124 nsq version 3.5.0 ] {
}
}
}
+
+ Class [ <internal:nsq> class NsqException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
}
}
diff --git a/php-pecl-nsq.spec b/php-pecl-nsq.spec
index 712e81b..f75b01a 100644
--- a/php-pecl-nsq.spec
+++ b/php-pecl-nsq.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-nsq
#
-# Copyright (c) 2018-2019 Remi Collet
+# Copyright (c) 2018-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -23,12 +23,13 @@
Summary: PHP extension for NSQ client
Name: %{?sub_prefix}php-pecl-nsq
-Version: 3.5.0
+Version: 3.5.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
License: PHP
-URL: http://pecl.php.net/package/nsq
+URL: https://pecl.php.net/package/nsq
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-json
@@ -49,30 +50,17 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{relea
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -159,16 +147,18 @@ done
%check
+OPTS="-n"
+[ -f %{php_extdir}/json.so ] && OPTS="$OPTS -d extension=json.so"
+
cd NTS
: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=json.so \
+%{__php} $OPTS \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=json.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+TEST_PHP_ARGS="$OPTS -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -177,14 +167,13 @@ REPORT_EXIT_STATUS=1 \
cd ../ZTS
: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=json.so \
+%{__ztsphp} $OPTS \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=json.so -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+TEST_PHP_ARGS="$OPTS -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
@@ -226,6 +215,9 @@ fi
%changelog
+* Sat Sep 18 2021 Remi Collet <remi@remirepo.net> - 3.5.1-1
+- update to 3.5.1
+
* Tue Oct 15 2019 Remi Collet <remi@remirepo.net> - 3.5.0-1
- update to 3.5.0