summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION98
-rw-r--r--php-pecl-mysql-xdevapi.spec5
3 files changed, 87 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 8f2779e..237c8f1 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.25
+Version => mysql_xdevapi 8.0.26
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index 6b7fe46..7269615 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
+Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.26 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -29,8 +29,8 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
}
- Constants [40] {
- Constant [ string MYSQLX_VERSION ] { 8.0.25 }
- Constant [ int MYSQLX_VERSION_ID ] { 80025 }
+ Constant [ string MYSQLX_VERSION ] { 8.0.26 }
+ Constant [ int MYSQLX_VERSION_ID ] { 80026 }
Constant [ int MYSQLX_CLIENT_SSL ] { 2048 }
Constant [ int MYSQLX_TYPE_DECIMAL ] { 0 }
Constant [ int MYSQLX_TYPE_TINY ] { 1 }
@@ -283,7 +283,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> abstract public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
}
@@ -308,6 +308,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [1] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -390,6 +393,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [1] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -435,6 +441,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [17] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method sql ] {
@@ -559,6 +568,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [3] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method getSession ] {
@@ -592,6 +604,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [12] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\DatabaseObject> public method getSession ] {
@@ -687,6 +702,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [16] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\DatabaseObject> public method getSession ] {
@@ -722,7 +740,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> $json ]
+ Parameter #0 [ <required> ...$json ]
}
}
@@ -810,6 +828,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [3] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Executable> public method execute ] {
@@ -821,7 +842,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> $json ]
+ Parameter #0 [ <required> ...$json ]
}
}
}
@@ -843,6 +864,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [11] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method fields ] {
@@ -855,7 +879,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method groupBy ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -876,7 +900,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationSortable> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -933,6 +957,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [12] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationBindable> public method bind ] {
@@ -945,7 +972,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationSortable> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -974,7 +1001,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method unset ] {
- Parameters [1] {
- Parameter #0 [ <required> $fields ]
+ Parameter #0 [ <required> ...$fields ]
}
}
@@ -1033,6 +1060,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [5] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationBindable> public method bind ] {
@@ -1045,7 +1075,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationSortable> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -1082,6 +1112,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [4] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method hasMoreResults ] {
@@ -1123,6 +1156,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method bind ] {
@@ -1204,6 +1240,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [5] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method fetchOne ] {
@@ -1248,6 +1287,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method getAffectedItemsCount ] {
@@ -1298,6 +1340,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [8] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method fetchOne ] {
@@ -1360,6 +1405,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [13] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method hasData ] {
@@ -1452,6 +1500,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [13] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method getSchemaName ] {
@@ -1545,6 +1596,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [11] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\DatabaseObject> public method getSession ] {
@@ -1627,6 +1681,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method where ] {
@@ -1639,7 +1696,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method orderby ] {
- Parameters [1] {
- Parameter #0 [ <required> $orderby_expr ]
+ Parameter #0 [ <required> ...$orderby_expr ]
}
}
@@ -1681,12 +1738,15 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [3] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method values ] {
- Parameters [1] {
- Parameter #0 [ <required> array $row_values ]
+ Parameter #0 [ <required> array ...$row_values ]
}
}
@@ -1714,6 +1774,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [11] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method where ] {
@@ -1726,7 +1789,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method groupBy ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expr ]
+ Parameter #0 [ <required> ...$sort_expr ]
}
}
@@ -1747,7 +1810,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method orderby ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expr ]
+ Parameter #0 [ <required> ...$sort_expr ]
}
}
@@ -1803,6 +1866,9 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
- Methods [7] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method set ] {
@@ -1823,7 +1889,7 @@ Extension [ <persistent> extension #86 mysql_xdevapi version 8.0.25 ] {
Method [ <internal:mysql_xdevapi> public method orderby ] {
- Parameters [1] {
- Parameter #0 [ <required> $orderby_expr ]
+ Parameter #0 [ <required> ...$orderby_expr ]
}
}
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 1259438..946f069 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -24,7 +24,7 @@
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.25
+Version: 8.0.26
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
@@ -307,6 +307,9 @@ fi
%changelog
+* Wed Jul 21 2021 Remi Collet <remi@remirepo.net> - 8.0.26-1
+- update to 8.0.26
+
* Tue May 11 2021 Remi Collet <remi@remirepo.net> - 8.0.25-1
- update to 8.0.25 (no change)