summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--0001-link-with-libresolv-for-ns_parserr.patch24
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION204
-rw-r--r--php-pecl-mysql-xdevapi.spec121
5 files changed, 250 insertions, 103 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/0001-link-with-libresolv-for-ns_parserr.patch b/0001-link-with-libresolv-for-ns_parserr.patch
new file mode 100644
index 0000000..05e161b
--- /dev/null
+++ b/0001-link-with-libresolv-for-ns_parserr.patch
@@ -0,0 +1,24 @@
+From edcb19e0f996a505025b4b4821db4e4b3e249220 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 30 Sep 2021 16:48:48 +0200
+Subject: [PATCH] link with libresolv for ns_parserr
+
+---
+ config.m4 | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/config.m4 b/config.m4
+index e96b9703..d40844f6 100644
+--- a/config.m4
++++ b/config.m4
+@@ -439,6 +439,7 @@ if test "$PHP_MYSQL_XDEVAPI" != "no" || test "$PHP_MYSQL_XDEVAPI_ENABLED" == "ye
+ fi
+ AC_MSG_RESULT($MYSQL_XDEVAPI_PROTOBUF_INCLUDES)
+
++ PHP_CHECK_LIBRARY(resolv, ns_parserr, [PHP_ADD_LIBRARY(resolv, 1, MYSQL_XDEVAPI_SHARED_LIBADD)])
+
+ dnl compressors
+ MYSQL_XDEVAPI_RESOLVE_COMPRESSOR("$PHP_LZ4", "lz4", "lz4", "LZ4F_createCompressionContext", "lz4.h", "MYSQL_XDEVAPI_HAVE_LZ4", IS_LZ4_ENABLED)
+--
+2.31.1
+
diff --git a/PHPINFO b/PHPINFO
index acfc68d..6dc9189 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.21
+Version => mysql_xdevapi 8.0.30
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index 917868c..622e31d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
+Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.30 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -29,8 +29,8 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Constants [40] {
- Constant [ string MYSQLX_VERSION ] { 8.0.21 }
- Constant [ int MYSQLX_VERSION_ID ] { 80021 }
+ Constant [ string MYSQLX_VERSION ] { 8.0.30 }
+ Constant [ int MYSQLX_VERSION_ID ] { 80030 }
Constant [ int MYSQLX_CLIENT_SSL ] { 2048 }
Constant [ int MYSQLX_TYPE_DECIMAL ] { 0 }
Constant [ int MYSQLX_TYPE_TINY ] { 1 }
@@ -82,7 +82,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Parameters [2] {
Parameter #0 [ <required> string $uri ]
- Parameter #1 [ <optional> string or NULL $client_options ]
+ Parameter #1 [ <optional> ?string $client_options = <default> ]
}
}
Function [ <internal:mysql_xdevapi> function mysql_xdevapi\expression ] {
@@ -283,7 +283,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> abstract public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
}
@@ -301,18 +301,21 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [3] {
- Property [ <default> public $message ]
- Property [ <default> public $level ]
- Property [ <default> public $code ]
+ Property [ public $message = NULL ]
+ Property [ public $level = NULL ]
+ Property [ public $code = NULL ]
}
- Methods [1] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Exception extends RuntimeException implements Throwable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Exception extends RuntimeException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -324,47 +327,81 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
@@ -381,15 +418,18 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [5] {
- Property [ <default> public $affectedItems ]
- Property [ <default> public $matchedItems ]
- Property [ <default> public $foundItems ]
- Property [ <default> public $lastInsertId ]
- Property [ <default> public $lastDocumentId ]
+ Property [ public $affectedItems = NULL ]
+ Property [ public $matchedItems = NULL ]
+ Property [ public $foundItems = NULL ]
+ Property [ public $lastInsertId = NULL ]
+ Property [ public $lastDocumentId = NULL ]
}
- Methods [1] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -406,7 +446,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [1] {
- Property [ <default> public $name ]
+ Property [ public $name = NULL ]
}
- Methods [1] {
@@ -435,6 +475,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [17] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method sql ] {
@@ -517,7 +560,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method setSavepoint ] {
- Parameters [1] {
- Parameter #0 [ <optional> $savepoint_name ]
+ Parameter #0 [ <optional> $savepoint_name = <default> ]
}
}
@@ -559,6 +602,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [3] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method getSession ] {
@@ -587,11 +633,14 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [1] {
- Property [ <default> public $name ]
+ Property [ public $name = NULL ]
}
- Methods [12] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\DatabaseObject> public method getSession ] {
@@ -616,7 +665,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Parameters [2] {
Parameter #0 [ <required> string $name ]
- Parameter #1 [ <optional> string $options ]
+ Parameter #1 [ <optional> string $options = <default> ]
}
}
@@ -682,11 +731,14 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [1] {
- Property [ <default> public $name ]
+ Property [ public $name = NULL ]
}
- Methods [16] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\DatabaseObject> public method getSession ] {
@@ -722,14 +774,14 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> $json ]
+ Parameter #0 [ <required> ...$json ]
}
}
Method [ <internal:mysql_xdevapi> public method find ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $search_condition ]
+ Parameter #0 [ <optional> string $search_condition = <default> ]
}
}
@@ -810,6 +862,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [3] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Executable> public method execute ] {
@@ -821,7 +876,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> $json ]
+ Parameter #0 [ <required> ...$json ]
}
}
}
@@ -843,6 +898,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [11] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method fields ] {
@@ -855,7 +913,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method groupBy ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -876,7 +934,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationSortable> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -897,21 +955,21 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method lockShared ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option = <default> ]
}
}
Method [ <internal:mysql_xdevapi> public method lockExclusive ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option = <default> ]
}
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Executable> public method execute ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $flags ]
+ Parameter #0 [ <optional> int $flags = <default> ]
}
}
}
@@ -933,6 +991,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [12] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationBindable> public method bind ] {
@@ -945,7 +1006,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationSortable> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -974,7 +1035,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method unset ] {
- Parameters [1] {
- Parameter #0 [ <required> $fields ]
+ Parameter #0 [ <required> ...$fields ]
}
}
@@ -1033,6 +1094,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [5] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationBindable> public method bind ] {
@@ -1045,7 +1109,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationSortable> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expressions ]
+ Parameter #0 [ <required> ...$sort_expressions ]
}
}
@@ -1082,6 +1146,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [4] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method hasMoreResults ] {
@@ -1118,11 +1185,14 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [1] {
- Property [ <default> public $statement ]
+ Property [ public $statement = NULL ]
}
- Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method bind ] {
@@ -1135,7 +1205,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method execute ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $flags ]
+ Parameter #0 [ <optional> int $flags = <default> ]
}
}
@@ -1188,7 +1258,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\DocResult implements mysql_xdevapi\BaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\DocResult implements mysql_xdevapi\BaseResult ] {
- Constants [0] {
}
@@ -1204,6 +1274,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [5] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method fetchOne ] {
@@ -1232,7 +1305,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\Result implements mysql_xdevapi\BaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\Result implements mysql_xdevapi\BaseResult ] {
- Constants [0] {
}
@@ -1248,6 +1321,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method getAffectedItemsCount ] {
@@ -1282,7 +1358,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\RowResult implements mysql_xdevapi\BaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\RowResult implements mysql_xdevapi\BaseResult ] {
- Constants [0] {
}
@@ -1298,6 +1374,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [8] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method fetchOne ] {
@@ -1344,7 +1423,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\SqlStatementResult implements mysql_xdevapi\BaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\SqlStatementResult implements mysql_xdevapi\BaseResult ] {
- Constants [0] {
}
@@ -1360,6 +1439,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [13] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method hasData ] {
@@ -1452,6 +1534,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [13] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method getSchemaName ] {
@@ -1540,11 +1625,14 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
}
- Properties [1] {
- Property [ <default> public $name ]
+ Property [ public $name = NULL ]
}
- Methods [11] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\DatabaseObject> public method getSession ] {
@@ -1627,6 +1715,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method where ] {
@@ -1639,7 +1730,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method orderby ] {
- Parameters [1] {
- Parameter #0 [ <required> $orderby_expr ]
+ Parameter #0 [ <required> ...$orderby_expr ]
}
}
@@ -1681,12 +1772,15 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [3] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method values ] {
- Parameters [1] {
- Parameter #0 [ <required> array $row_values ]
+ Parameter #0 [ <required> array ...$row_values ]
}
}
@@ -1714,6 +1808,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [11] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method where ] {
@@ -1726,7 +1823,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method groupBy ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expr ]
+ Parameter #0 [ <required> ...$sort_expr ]
}
}
@@ -1747,7 +1844,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method orderby ] {
- Parameters [1] {
- Parameter #0 [ <required> $sort_expr ]
+ Parameter #0 [ <required> ...$sort_expr ]
}
}
@@ -1768,14 +1865,14 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method lockShared ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option = <default> ]
}
}
Method [ <internal:mysql_xdevapi> public method lockExclusive ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option = <default> ]
}
}
@@ -1803,6 +1900,9 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Methods [7] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:mysql_xdevapi> public method set ] {
@@ -1823,7 +1923,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
Method [ <internal:mysql_xdevapi> public method orderby ] {
- Parameters [1] {
- Parameter #0 [ <required> $orderby_expr ]
+ Parameter #0 [ <required> ...$orderby_expr ]
}
}
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index ba8df6c..848ea1d 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -1,19 +1,13 @@
# remirepo spec file for php-pecl-mysql-xdevapi
#
-# Copyright (c) 2016-2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-mysql-xdevapi
-%endif
+%{?scl:%scl_package php-pecl-mysql-xdevapi}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mysql_xdevapi
@@ -21,19 +15,25 @@
%bcond_with tests
# After 20-json, 20-mysqlnd
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
+
Summary: MySQL database access functions
-Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.21
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Name: %{?scl_prefix}php-pecl-mysql-xdevapi
+Version: 8.0.30
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
+License: PHP-3.0.1
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
+Patch0: 0001-link-with-libresolv-for-ns_parserr.patch
+
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-json
@@ -52,7 +52,6 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-hash%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -67,26 +66,18 @@ Obsoletes: %{name}-devel < 8.0.2
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -121,14 +112,14 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-mv %{pecl_name}-%{version} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
+cd %{sources}
+%patch -P0 -p1
# Check version as upstream often forget to update this
extver=$(sed -n '/#define PHP_MYSQL_XDEVAPI_VERSION/{s/.* "//;s/".*$//;p}' php_mysql_xdevapi.h)
@@ -138,10 +129,9 @@ if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
fi
cd ..
-
+mkdir NTS
%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -170,15 +160,16 @@ peclconf() {
--with-php-config=$1
}
-cd NTS
-%{_bindir}/phpize
-peclconf %{_bindir}/php-config
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+peclconf %{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
-peclconf %{_bindir}/zts-php-config
+peclconf %{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -201,34 +192,31 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do [ -f %{sources}/$i ] && install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
-cd NTS
+cd %{sources}
+
+OPT="-n -d extension=mysqlnd.so"
+[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
: Minimal load test for NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension=mysqlnd.so \
- --define extension=json.so \
+%{__php} $OPT \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=mysqlnd.so \
- --define extension=json.so \
+%{__ztsphp} $OPT \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%endif
%if %{with tests}
-cd ../NTS
RET=0
: Running a server
@@ -303,7 +291,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -317,6 +305,39 @@ fi
%changelog
+* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 8.0.30-2
+- build out of sources tree
+
+* Tue Jul 26 2022 Remi Collet <remi@remirepo.net> - 8.0.30-1
+- update to 8.0.30
+
+* Tue Apr 26 2022 Remi Collet <remi@remirepo.net> - 8.0.29-1
+- update to 8.0.29
+
+* Tue Jan 18 2022 Remi Collet <remi@remirepo.net> - 8.0.28-1
+- update to 8.0.28
+
+* Tue Oct 19 2021 Remi Collet <remi@remirepo.net> - 8.0.27-1
+- update to 8.0.27 (no change)
+
+* Thu Sep 30 2021 Remi Collet <remi@remirepo.net> - 8.0.26-2
+- fix F35 build adding libresolv to linked libraries
+
+* Wed Jul 21 2021 Remi Collet <remi@remirepo.net> - 8.0.26-1
+- update to 8.0.26
+
+* Tue May 11 2021 Remi Collet <remi@remirepo.net> - 8.0.25-1
+- update to 8.0.25 (no change)
+
+* Tue Apr 27 2021 Remi Collet <remi@remirepo.net> - 8.0.24-1
+- update to 8.0.24
+
+* Mon Jan 18 2021 Remi Collet <remi@remirepo.net> - 8.0.23-1
+- update to 8.0.23
+
+* Mon Oct 19 2020 Remi Collet <remi@remirepo.net> - 8.0.22-1
+- update to 8.0.22
+
* Mon Jul 13 2020 Remi Collet <remi@remirepo.net> - 8.0.21-1
- update to 8.0.21
- raise dependency on protobuf 3 (drop EL-7 compatibility)