summaryrefslogtreecommitdiffstats
path: root/php-pecl-mustache.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mustache.spec')
-rw-r--r--php-pecl-mustache.spec30
1 files changed, 14 insertions, 16 deletions
diff --git a/php-pecl-mustache.spec b/php-pecl-mustache.spec
index 8914e71..0fcaaf4 100644
--- a/php-pecl-mustache.spec
+++ b/php-pecl-mustache.spec
@@ -13,31 +13,25 @@
%global pecl_name mustache
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 0.7.4
+%global upstream_version 0.8.0
#global upstream_prever RC2
Summary: Mustache templating language
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-
-Patch0: https://patch-diff.githubusercontent.com/raw/jbboehr/php-mustache/pull/48.patch
+Source1: https://raw.githubusercontent.com/jbboehr/php-mustache/master/php5to7.h
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 5.4
+BuildRequires: %{?scl_prefix}php-devel >= 5.6
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: pkgconfig(mustache)
+BuildRequires: pkgconfig(mustache) >= 0.5.0
%if 0%{?rhel} == 7
BuildRequires: devtoolset-6-toolchain
%else
@@ -103,7 +97,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr48
+cp %{SOURCE1} .
# Sanity check, really often broken
extver=$(sed -n '/PHP_MUSTACHE_VERSION/{s/.* "//;s/".*$//;p}' php_mustache.h)
@@ -198,10 +192,6 @@ fi
%check
-%if 0%{?fedora} >= 28
-rm ?TS/tests/MustacheCode__toReadableString.phpt
-%endif
-
: Minimal load test for NTS extension
cd NTS
%{__php} --no-php-ini \
@@ -251,7 +241,15 @@ REPORT_EXIT_STATUS=1 \
%endif
+# Notice no more EL-6 build (compiler issue and segfaults)
%changelog
+* Mon Nov 12 2018 Remi Collet <remi@remirepo.net> - 0.8.0-1
+- update to 0.8.0
+- drop patch merged upstream
+- raise dependency on PHP 5.6
+- raise dependency on libmustache 0.5.0
+- open https://github.com/jbboehr/php-mustache/pull/52 missing file
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 0.7.4-5
- rebuild for 7.3.0beta2 new ABI