summaryrefslogtreecommitdiffstats
path: root/php-pecl-msgpack-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-msgpack-dev.spec')
-rw-r--r--php-pecl-msgpack-dev.spec197
1 files changed, 197 insertions, 0 deletions
diff --git a/php-pecl-msgpack-dev.spec b/php-pecl-msgpack-dev.spec
new file mode 100644
index 0000000..c2fae0a
--- /dev/null
+++ b/php-pecl-msgpack-dev.spec
@@ -0,0 +1,197 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global pecl_name msgpack
+
+Summary: API for communicating with MessagePack serialization
+Name: php-pecl-msgpack
+Version: 0.5.5
+Release: 2%{?dist}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/msgpack
+Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# https://github.com/msgpack/msgpack-php/issues/16
+Patch0: %{pecl_name}.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: php-devel
+BuildRequires: php-pear
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+%if "%{php_version}" > "5.4"
+Obsoletes: php54-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.5"
+Obsoletes: php55-pecl-%{pecl_name}
+%endif
+
+
+# Filter private shared
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+
+%description
+This extension provide API for communicating with MessagePack serialization.
+
+MessagePack is an efficient binary serialization format. It lets you exchange
+data among multiple languages like JSON but it's faster and smaller.
+For example, small integers (like flags or error code) are encoded into a
+single byte, and typical short strings only require an extra byte in addition
+to the strings themselves.
+
+If you ever wished to use JSON for convenience (storing an image with metadata)
+but could not for technical reasons (encoding, size, speed...), MessagePack is
+a perfect replacement.
+
+This extension is still EXPERIMENTAL.
+
+
+%package devel
+Summary: MessagePack developer files (header)
+Group: Development/Libraries
+Requires: php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+Requires: php-devel%{?_isa}
+
+%description devel
+These are the files needed to compile programs using MessagePack serializer.
+
+
+%prep
+%setup -q -c
+
+cd %{pecl_name}-%{version}
+%patch0 -p1 -b .build
+
+# When this file will be removed, clean the description.
+[ -f EXPERIMENTAL ] || exit 1
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define MSGPACK_EXTENSION_VERSION/{s/.* "//;s/".*$//;p}' php_msgpack.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+# duplicate for ZTS build
+cp -pr %{pecl_name}-%{version} %{pecl_name}-zts
+
+# Drop in the bit of configuration
+cat > %{pecl_name}.ini << 'EOF'
+; Enable MessagePack extension module
+extension = %{pecl_name}.so
+
+; Configuration options
+
+;msgpack.error_display = On
+;msgpack.illegal_key_insert = Off
+;msgpack.php_only = On
+EOF
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+# Install the NTS stuff
+make -C %{pecl_name}-%{version} install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+
+# Install the ZTS stuff
+make -C %{pecl_name}-zts install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+
+# Install the package XML file
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+
+%check
+cd %{pecl_name}-%{version}
+
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php
+
+cd ../%{pecl_name}-zts
+
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-, root, root, 0755)
+%doc %{pecl_name}-%{version}/{ChangeLog,CREDITS,LICENSE,README.md}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_ztsextdir}/%{pecl_name}.so
+
+
+%files devel
+%defattr(-, root, root, 0755)
+%{php_incldir}/ext/%{pecl_name}
+%{php_ztsincldir}/ext/%{pecl_name}
+
+
+%changelog
+* Wed Mar 26 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-2
+- cleanups
+
+* Wed Feb 20 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-1
+- Update to 0.5.5
+
+* Fri Nov 30 2012 Remi Collet <remi@fedoraproject.org> - 0.5.3-1.1
+- also provides php-msgpack
+
+* Thu Oct 18 2012 Remi Collet <remi@fedoraproject.org> - 0.5.3-1
+- update to 0.5.3 (beta)
+
+* Sat Sep 15 2012 Remi Collet <remi@fedoraproject.org> - 0.5.2-1
+- initial package, version 0.5.2 (beta)
+