summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--msgpack.patch12
-rw-r--r--php-pecl-msgpack.spec13
2 files changed, 23 insertions, 2 deletions
diff --git a/msgpack.patch b/msgpack.patch
new file mode 100644
index 0000000..bd440db
--- /dev/null
+++ b/msgpack.patch
@@ -0,0 +1,12 @@
+--- msgpack-0.5.5/msgpack_unpack.h.old 2013-02-19 04:03:35.000000000 +0100
++++ msgpack-0.5.5/msgpack_unpack.h 2013-02-20 09:55:53.969440978 +0100
+@@ -67,6 +67,9 @@
+ int msgpack_unserialize_map_item(
+ msgpack_unserialize_data *unpack, zval **container, zval *key, zval *val);
+
++void msgpack_serialize_var_destroy(msgpack_serialize_data_t *var_hash);
++void msgpack_serialize_var_init(msgpack_serialize_data_t *var_hash);
++
+ /* template functions */
+ #define msgpack_unpack_struct(name) struct template ## name
+ #define msgpack_unpack_func(ret, name) ret template ## name
diff --git a/php-pecl-msgpack.spec b/php-pecl-msgpack.spec
index 5d8569a..ee4d763 100644
--- a/php-pecl-msgpack.spec
+++ b/php-pecl-msgpack.spec
@@ -5,13 +5,16 @@
Summary: API for communicating with MessagePack serialization
Name: php-pecl-msgpack
-Version: 0.5.3
-Release: 1%{?dist}.4
+Version: 0.5.5
+Release: 1%{?dist}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/msgpack
Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# https://github.com/msgpack/msgpack-php/issues/16
+Patch0: %{pecl_name}.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: php-devel, php-pear
@@ -72,6 +75,9 @@ These are the files needed to compile programs using MessagePack serializer.
cd %{pecl_name}-%{version}
+%patch0 -p1 -b .build
+
+
# When this file will be removed, clean the description.
[ -f EXPERIMENTAL ] || exit 1
@@ -188,6 +194,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Feb 20 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-1
+- Update to 0.5.5
+
* Fri Nov 30 2012 Remi Collet <remi@fedoraproject.org> - 0.5.3-1.1
- also provides php-msgpack