summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--174.patch78
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-msgpack.spec16
4 files changed, 10 insertions, 88 deletions
diff --git a/174.patch b/174.patch
deleted file mode 100644
index 1d74f6f..0000000
--- a/174.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From da2e275aff642de43b94260ac1715379de9572ba Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 5 Jul 2024 11:47:33 +0200
-Subject: [PATCH] fix tests for 8.4
-
----
- tests/015.phpt | 2 +-
- tests/015b.phpt | 2 +-
- tests/015e.phpt | 2 +-
- tests/027.phpt | 2 +-
- tests/028.phpt | 2 +-
- 5 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/tests/015.phpt b/tests/015.phpt
-index 4bd0f52..9e053aa 100644
---- a/tests/015.phpt
-+++ b/tests/015.phpt
-@@ -46,7 +46,7 @@ function gc($time) {
-
- ini_set('session.serialize_handler', 'msgpack');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
- session_start();
-
-diff --git a/tests/015b.phpt b/tests/015b.phpt
-index de383ee..b736fb5 100644
---- a/tests/015b.phpt
-+++ b/tests/015b.phpt
-@@ -45,7 +45,7 @@ function gc($time) {
- return true;
- }
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
- session_start();
-
-diff --git a/tests/015e.phpt b/tests/015e.phpt
-index b18a34a..0598d42 100644
---- a/tests/015e.phpt
-+++ b/tests/015e.phpt
-@@ -48,7 +48,7 @@ function gc($time) {
-
- ini_set('session.serialize_handler', 'msgpack');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
- session_start();
-
-diff --git a/tests/027.phpt b/tests/027.phpt
-index c8f89ab..49cf193 100644
---- a/tests/027.phpt
-+++ b/tests/027.phpt
-@@ -53,7 +53,7 @@ class Bar {
-
- ini_set('session.serialize_handler', 'msgpack');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
-
- $db_object = new Foo();
-diff --git a/tests/028.phpt b/tests/028.phpt
-index a55b90b..a5f7637 100644
---- a/tests/028.phpt
-+++ b/tests/028.phpt
-@@ -88,7 +88,7 @@ function gc($time) {
-
- ini_set('session.serialize_handler', 'msgpack');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
- session_start();
-
diff --git a/PHPINFO b/PHPINFO
index 40076fa..833600b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -4,7 +4,7 @@ msgpack
MessagePack Support => enabled
Session Support => enabled
MessagePack APCu Serializer ABI => 0
-extension Version => 3.0.0RC1
+extension Version => 3.0.0
header Version => 3.2.0
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index adf666c..9bfed2c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #84 msgpack version 3.0.0RC1 ] {
+Extension [ <persistent> extension #87 msgpack version 3.0.0 ] {
- INI {
Entry [ msgpack.error_display <ALL> ]
diff --git a/php-pecl-msgpack.spec b/php-pecl-msgpack.spec
index 658672e..6a0162a 100644
--- a/php-pecl-msgpack.spec
+++ b/php-pecl-msgpack.spec
@@ -20,7 +20,7 @@
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 3.0.0
-%global upstream_prever RC1
+#global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -35,7 +35,7 @@ Name: %{?scl_prefix}php-pecl-msgpack
License: BSD-3-Clause
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
URL: https://pecl.php.net/package/msgpack
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: make
@@ -181,9 +181,10 @@ rm */tests/035.phpt
%endif
%if "%{php_version}" > "7.4"
-OPT="-q --show-diff %{?_smp_mflags}"
+OPT="-q -P --show-diff %{?_smp_mflags}"
%else
-OPT="-q --show-diff"
+OPT="-q -P --show-diff"
+export REPORT_EXIT_STATUS=1
%endif
cd %{sources}
@@ -194,9 +195,7 @@ cd %{sources}
%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=apcu.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php $OPT
%endif
@@ -208,9 +207,7 @@ REPORT_EXIT_STATUS=1 \
%if %{with tests}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=apcu.so -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php $OPT
%endif
%endif
@@ -240,6 +237,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Sep 26 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+
* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 3.0.0~RC1-2
- rebuild for 8.4.0RC1