summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION-PHP7173
-rw-r--r--php-pecl-msgpack-php7.spec (renamed from php-pecl-msgpack-dev.spec)9
2 files changed, 179 insertions, 3 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..0b18f05
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,173 @@
+Extension [ <persistent> extension #81 msgpack version 2.0.0 ] {
+
+ - INI {
+ Entry [ msgpack.error_display <ALL> ]
+ Current = '1'
+ }
+ Entry [ msgpack.php_only <ALL> ]
+ Current = '1'
+ }
+ Entry [ msgpack.illegal_key_insert <ALL> ]
+ Current = '0'
+ }
+ Entry [ msgpack.use_str8_serialization <ALL> ]
+ Current = '1'
+ }
+ }
+
+ - Constants [1] {
+ Constant [ integer MESSAGEPACK_OPT_PHPONLY ] { -1001 }
+ }
+
+ - Functions {
+ Function [ <internal:msgpack> function msgpack_serialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ Function [ <internal:msgpack> function msgpack_unserialize ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $str ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:msgpack> function msgpack_pack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ Function [ <internal:msgpack> function msgpack_unpack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $str ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+ }
+
+ - Classes [2] {
+ Class [ <internal:msgpack> class MessagePack ] {
+
+ - Constants [1] {
+ Constant [ integer OPT_PHPONLY ] { -1001 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:msgpack, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $opt ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method setOption ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $option ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method pack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method unpack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $str ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method unpacker ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:msgpack> class MessagePackUnpacker ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:msgpack, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $opt ]
+ }
+ }
+
+ Method [ <internal:msgpack, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:msgpack> public method setOption ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $option ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method feed ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $str ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method execute ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $str ]
+ Parameter #1 [ <optional> &$offset ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method data ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:msgpack> public method reset ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-msgpack-dev.spec b/php-pecl-msgpack-php7.spec
index d657e67..07e1dfe 100644
--- a/php-pecl-msgpack-dev.spec
+++ b/php-pecl-msgpack-php7.spec
@@ -22,11 +22,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit 75991cf1cd22b8a27f8e09e9a0ee6129473f3f21
+%global gh_commit b29f3fd572b9d2ad8c053efa6279f93862f63657
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner msgpack
%global gh_project msgpack-php
-%global gh_date 20151014
+#global gh_date 20151014
%global pecl_name msgpack
%global with_zts 0%{?__ztsphp:1}
%if "%{php_version}" < "5.6"
@@ -55,7 +55,7 @@ URL: http://pecl.php.net/package/msgpack
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
%if %{with_msgpack}
BuildRequires: msgpack-devel
@@ -292,6 +292,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 (php 7)
+
* Wed Oct 14 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.1.20151014git75991cf
- new snapshot, version bump to 2.0.0dev