summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 0e8f74d..43ab88a 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -26,7 +26,7 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 99 || 0%{?rhel} >= 9
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%bcond_without syslib
%else
%bcond_with syslib
@@ -39,15 +39,15 @@
%global libcrypt 1.2.1
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
-%global libmongo 1.18.0~alpha
-%global libcrypt 1.2.1~dev
+%global libmongo 1.18.0
+%global libcrypt 1.2.1
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.10.0
-%global upstream_prever alpha1
-%global upstream_lower ~alpha1
+#global upstream_prever alpha1
+#global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -56,7 +56,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with syslib}
@@ -122,6 +122,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -335,6 +338,12 @@ exit $ret
%changelog
+* Wed Jul 14 2021 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0
+- with libbson and libmongoc 1.18.0
+- with libmongocrypt 1.2.1
+- raise dependency on PHP 7.1
+
* Fri Apr 9 2021 Remi Collet <remi@remirepo.net> - 1.10.0~alpha1-1
- update to 1.10.0alpha1
- with libbson and libmongoc 1.18.0alpha