summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec44
1 files changed, 19 insertions, 25 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 2ff8a5d..2b3f7d9 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -21,7 +21,6 @@
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
%global ini_name 50-%{pecl_name}.ini
%endif
-#global prever alpha3
%ifarch x86_64
%global with_tests 0%{?_with_tests:1}
@@ -32,7 +31,7 @@
%global with_tests 0%{?_with_tests:1}
%endif
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} >= 27
%global with_syslib 1
%else
%global with_syslib 0
@@ -40,12 +39,14 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.9
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%global upstream_version 1.3.0
+%global upstream_prever beta1
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
@@ -53,12 +54,14 @@ BuildRequires: %{?scl_prefix}php-json
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
%if %{with_syslib}
-BuildRequires: pkgconfig(libbson-1.0) >= 1.6
-BuildRequires: pkgconfig(libmongoc-1.0) >= 1.6
+BuildRequires: pkgconfig(libbson-1.0) >= 1.7
+BuildRequires: pkgconfig(libmongoc-1.0) >= 1.7
%else
-Provides: bundled(libbson) = 1.6.1
-Provides: bundled(mongo-c-driver) = 1.6.1
+Provides: bundled(libbson) = 1.7.0
+Provides: bundled(mongo-c-driver) = 1.7.0
%endif
+BuildRequires: snappy-devel
+BuildRequires: zlib-devel
%if %{with_tests}
BuildRequires: mongodb-server
%endif
@@ -121,7 +124,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version}%{?prever} NTS
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -132,8 +135,8 @@ cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
-if test "x${extver}" != "x%{version}%{?prever:%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:%{prever}}.
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
fi
cd ..
@@ -270,19 +273,6 @@ if [ -s server.pid ] ; then
: Drop known to fail tests
%if "%{mongo_version}" < "3.4"
### With mongodb 3.2
- rm ?TS/tests/standalone/bug0231.phpt
-%endif
-%if "%{mongo_version}" < "3.2"
- ### With mongodb 3.0
- rm ?TS/tests/manager/manager-executeBulkWrite-011.phpt
- rm ?TS/tests/manager/manager-executeQuery-002.phpt
- rm ?TS/tests/readPreference/bug0146-002.phpt
-%endif
-%if "%{mongo_version}" < "3.0"
- ### Older mongodb
- rm ?TS/tests/bulk/write-0003.phpt
- rm ?TS/tests/manager/manager-executeBulkWrite_error-001.phpt
- rm ?TS/tests/manager/manager-executeBulkWrite_error-002.phpt
%endif
: Run the test suite
@@ -331,6 +321,10 @@ exit $ret
%changelog
+* Fri Aug 11 2017 Remi Collet <remi@remirepo.net> - 1.3.0~beta1-1
+- update to 1.3.0beta1
+- raise dependency on libbson and mongo-c-driver 1.7.0
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.2.9-4
- rebuild for PHP 7.2.0beta1 new API