summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec10
1 files changed, 9 insertions, 1 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 2b3f7d9..3903373 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -42,12 +42,15 @@ Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.3.0
%global upstream_prever beta1
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+# https://github.com/mongodb/mongo-php-driver/pull/633
+Patch0: %{pecl_name}-pr633.patch
+
BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -132,6 +135,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .pr633
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
@@ -321,6 +325,10 @@ exit $ret
%changelog
+* Wed Aug 23 2017 Remi Collet <remi@remirepo.net> - 1.3.0~beta1-2
+- add patch for upcoming PHP 7.2.0RC1 and new timelib from
+ https://github.com/mongodb/mongo-php-driver/pull/633
+
* Fri Aug 11 2017 Remi Collet <remi@remirepo.net> - 1.3.0~beta1-1
- update to 1.3.0beta1
- raise dependency on libbson and mongo-c-driver 1.7.0