summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec18
1 files changed, 12 insertions, 6 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 2ff8a5d..843903a 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -32,6 +32,7 @@
%global with_tests 0%{?_with_tests:1}
%endif
+%global libver 1.5.5
%if 0%{?fedora} >= 26
%global with_syslib 1
%else
@@ -40,8 +41,8 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.9
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.10
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -53,12 +54,14 @@ BuildRequires: %{?scl_prefix}php-json
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
%if %{with_syslib}
-BuildRequires: pkgconfig(libbson-1.0) >= 1.6
-BuildRequires: pkgconfig(libmongoc-1.0) >= 1.6
+BuildRequires: pkgconfig(libbson-1.0) >= %{libver}
+BuildRequires: pkgconfig(libmongoc-1.0) >= %{libver}
%else
-Provides: bundled(libbson) = 1.6.1
-Provides: bundled(mongo-c-driver) = 1.6.1
+Provides: bundled(libbson) = %{libver}
+Provides: bundled(mongo-c-driver) = %{libver}
%endif
+BuildRequires: snappy-devel
+BuildRequires: zlib-devel
%if %{with_tests}
BuildRequires: mongodb-server
%endif
@@ -331,6 +334,9 @@ exit $ret
%changelog
+* Thu Sep 7 2017 Remi Collet <remi@remirepo.net> - 1.2.10-1
+- Update to 1.2.10
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.2.9-4
- rebuild for PHP 7.2.0beta1 new API