summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-14 15:57:59 +0200
committerRemi Collet <remi@remirepo.net>2021-07-14 15:57:59 +0200
commit115f808354bb8e018242c33729ffc6bc3b077e58 (patch)
tree76332b1f5d20097d2aae81c13e5fef8167d18b72
parent3e8c1ef24c2258f298c31b83695ac252d8a4b67a (diff)
update to 1.10.0
with libbson and libmongoc 1.18.0 with libmongocrypt 1.2.1 raise dependency on PHP 7.1
-rw-r--r--PHPINFO13
-rw-r--r--REFLECTION30
-rw-r--r--php-pecl-mongodb.spec21
3 files changed, 48 insertions, 16 deletions
diff --git a/PHPINFO b/PHPINFO
index fcdc160..698bac3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,10 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.10.0alpha1
-MongoDB extension stability => alpha
-libbson bundled version => 1.18.0-alpha
-libmongoc bundled version => 1.18.0-alpha
+MongoDB extension version => 1.10.0
+MongoDB extension stability => stable
+libbson headers version => 1.18.0
+libbson library version => 1.18.0
+libmongoc headers version => 1.18.0
+libmongoc library version => 1.18.0
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -17,7 +19,8 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt bundled version => 1.2.1-dev+20210209git79f5bda042
+libmongocrypt headers version => 1.2.1
+libmongocrypt library version => 1.2.1
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
diff --git a/REFLECTION b/REFLECTION
index ddb1f13..9d3b74b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 mongodb version 1.10.0alpha1 ] {
+Extension [ <persistent> extension #117 mongodb version 1.10.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #115 mongodb version 1.10.0alpha1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.10.0alpha1 }
- Constant [ string MONGODB_STABILITY ] { alpha }
+ Constant [ string MONGODB_VERSION ] { 1.10.0 }
+ Constant [ string MONGODB_STABILITY ] { stable }
}
- Functions {
@@ -1447,7 +1447,13 @@ Extension [ <persistent> extension #115 mongodb version 1.10.0alpha1 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
}
- Properties [0] {
@@ -1501,7 +1507,7 @@ Extension [ <persistent> extension #115 mongodb version 1.10.0alpha1 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [17] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
@@ -1511,6 +1517,13 @@ Extension [ <persistent> extension #115 mongodb version 1.10.0alpha1 ] {
}
}
+ Method [ <internal:mongodb> final public method addSubscriber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\Subscriber $subscriber ]
+ }
+ }
+
Method [ <internal:mongodb> final public method createClientEncryption ] {
- Parameters [1] {
@@ -1596,6 +1609,13 @@ Extension [ <persistent> extension #115 mongodb version 1.10.0alpha1 ] {
}
}
+ Method [ <internal:mongodb> final public method removeSubscriber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\Subscriber $subscriber ]
+ }
+ }
+
Method [ <internal:mongodb> final public method selectServer ] {
- Parameters [1] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 0e8f74d..43ab88a 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -26,7 +26,7 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 99 || 0%{?rhel} >= 9
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%bcond_without syslib
%else
%bcond_with syslib
@@ -39,15 +39,15 @@
%global libcrypt 1.2.1
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
-%global libmongo 1.18.0~alpha
-%global libcrypt 1.2.1~dev
+%global libmongo 1.18.0
+%global libcrypt 1.2.1
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.10.0
-%global upstream_prever alpha1
-%global upstream_lower ~alpha1
+#global upstream_prever alpha1
+#global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -56,7 +56,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with syslib}
@@ -122,6 +122,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -335,6 +338,12 @@ exit $ret
%changelog
+* Wed Jul 14 2021 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0
+- with libbson and libmongoc 1.18.0
+- with libmongocrypt 1.2.1
+- raise dependency on PHP 7.1
+
* Fri Apr 9 2021 Remi Collet <remi@remirepo.net> - 1.10.0~alpha1-1
- update to 1.10.0alpha1
- with libbson and libmongoc 1.18.0alpha