summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-06 07:33:31 +0100
committerRemi Collet <remi@remirepo.net>2019-12-06 07:33:31 +0100
commitc415d7b3504e0e2768c95e53c03de33ab11e82fc (patch)
tree47d1447edbad2265a88b251260d3b3317229b16f
parenta08778fd7cc36d575d4780630c5857be3dd2fc71 (diff)
v1.6.1
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION50
-rw-r--r--php-pecl-mongodb.spec7
3 files changed, 35 insertions, 32 deletions
diff --git a/PHPINFO b/PHPINFO
index 63d2535..bc38217 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.6.0
+MongoDB extension version => 1.6.1
MongoDB extension stability => stable
-libbson headers version => 1.15.1
-libbson library version => 1.15.1
-libmongoc headers version => 1.15.1
-libmongoc library version => 1.15.1
+libbson headers version => 1.15.2
+libbson library version => 1.15.2
+libmongoc headers version => 1.15.2
+libmongoc library version => 1.15.2
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
diff --git a/REFLECTION b/REFLECTION
index fb7fd39..ce233f2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #194 mongodb version 1.6.0 ] {
+Extension [ <persistent> extension #182 mongodb version 1.6.1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.6.0 }
+ Constant [ string MONGODB_VERSION ] { 1.6.1 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -396,13 +396,13 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0 ] {
Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements MongoDB\BSON\BinaryInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [7] {
- Constant [ public integer TYPE_GENERIC ] { 0 }
- Constant [ public integer TYPE_FUNCTION ] { 1 }
- Constant [ public integer TYPE_OLD_BINARY ] { 2 }
- Constant [ public integer TYPE_OLD_UUID ] { 3 }
- Constant [ public integer TYPE_UUID ] { 4 }
- Constant [ public integer TYPE_MD5 ] { 5 }
- Constant [ public integer TYPE_USER_DEFINED ] { 128 }
+ Constant [ public int TYPE_GENERIC ] { 0 }
+ Constant [ public int TYPE_FUNCTION ] { 1 }
+ Constant [ public int TYPE_OLD_BINARY ] { 2 }
+ Constant [ public int TYPE_OLD_UUID ] { 3 }
+ Constant [ public int TYPE_UUID ] { 4 }
+ Constant [ public int TYPE_MD5 ] { 5 }
+ Constant [ public int TYPE_USER_DEFINED ] { 128 }
}
- Static properties [0] {
@@ -1598,13 +1598,13 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\ReadPreference implements MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
- Constants [7] {
- Constant [ public integer RP_PRIMARY ] { 1 }
- Constant [ public integer RP_PRIMARY_PREFERRED ] { 5 }
- Constant [ public integer RP_SECONDARY ] { 2 }
- Constant [ public integer RP_SECONDARY_PREFERRED ] { 6 }
- Constant [ public integer RP_NEAREST ] { 10 }
- Constant [ public integer NO_MAX_STALENESS ] { -1 }
- Constant [ public integer SMALLEST_MAX_STALENESS_SECONDS ] { 90 }
+ Constant [ public int RP_PRIMARY ] { 1 }
+ Constant [ public int RP_PRIMARY_PREFERRED ] { 5 }
+ Constant [ public int RP_SECONDARY ] { 2 }
+ Constant [ public int RP_SECONDARY_PREFERRED ] { 6 }
+ Constant [ public int RP_NEAREST ] { 10 }
+ Constant [ public int NO_MAX_STALENESS ] { -1 }
+ Constant [ public int SMALLEST_MAX_STALENESS_SECONDS ] { 90 }
}
- Static properties [0] {
@@ -1661,15 +1661,15 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\Server ] {
- Constants [9] {
- Constant [ public integer TYPE_UNKNOWN ] { 0 }
- Constant [ public integer TYPE_STANDALONE ] { 1 }
- Constant [ public integer TYPE_MONGOS ] { 2 }
- Constant [ public integer TYPE_POSSIBLE_PRIMARY ] { 3 }
- Constant [ public integer TYPE_RS_PRIMARY ] { 4 }
- Constant [ public integer TYPE_RS_SECONDARY ] { 5 }
- Constant [ public integer TYPE_RS_ARBITER ] { 6 }
- Constant [ public integer TYPE_RS_OTHER ] { 7 }
- Constant [ public integer TYPE_RS_GHOST ] { 8 }
+ Constant [ public int TYPE_UNKNOWN ] { 0 }
+ Constant [ public int TYPE_STANDALONE ] { 1 }
+ Constant [ public int TYPE_MONGOS ] { 2 }
+ Constant [ public int TYPE_POSSIBLE_PRIMARY ] { 3 }
+ Constant [ public int TYPE_RS_PRIMARY ] { 4 }
+ Constant [ public int TYPE_RS_SECONDARY ] { 5 }
+ Constant [ public int TYPE_RS_ARBITER ] { 6 }
+ Constant [ public int TYPE_RS_OTHER ] { 7 }
+ Constant [ public int TYPE_RS_GHOST ] { 8 }
}
- Static properties [0] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index aa00d75..c18024a 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -36,12 +36,12 @@
%global libbuildver %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libver})
%else
%global with_syslib 0
-%global libver 1.15.1
+%global libver 1.15.2
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.6.0
+%global upstream_version 1.6.1
#global upstream_prever RC1
#global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
@@ -328,6 +328,9 @@ exit $ret
%changelog
+* Fri Dec 6 2019 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- update to 1.6.1
+
* Mon Sep 9 2019 Remi Collet <remi@remirepo.net> - 1.6.0-1
- update to 1.6.0